Jump to content

Atari VCS bios menu won't load anymore


Recommended Posts

I did what a youtube video online said which was to keep hitting delete upon bootup  of Atari VCS and it went to an option to go into the bios settings menu of the console.  


It said to go down to settings option and when I selected it it asked for a password.  The video said it was Piano18482 but I tried it and it didn't work.  I tried it three times and then got a message that said "password wrong three times.  Reset console". 


Now every time I hit "delete" on my keyboard upon bootup, I don't get a menu to select going into bios settings anymore.  Just some gibberish characters in the top left of the screen.  What happened?  

Link to comment
Share on other sites

16 hours ago, jbrunick said:

You’ll need to re-flash the BIOS back to an older version. There is a pretty good description on how to do it, including links, in the password thread (page 12, I think).

OP was using an old password,  but If none of the known passwords get you into BIOS,  then this ^ is the fix

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...