Jump to content

GameDrive stuck on QR code screen


Recommended Posts

Hi all,

Got a brand new GameDrive and it was working perfectly fine the first time I inserted a microSD card into it with a few games copied onto it. When I rebooted the device, the QR code screen came up and it's been stuck on that screen ever since. I tried copying the latest firmware file to the SD card and even reformatting the card, but nothing seems to move me beyond the QR code screen. Any ideas?



Link to comment
Share on other sites

Hi SainT,

Alas, it boots into the QR code screen even with no controllers attached. I've also noticed it still boots into the QR code screen even when the SD card is removed, when previously it would warn that a card was required. Nothing I do seems to progress beyond that screen.

Link to comment
Share on other sites

Huh, odd, the file is now downloading as .ovr not .upd -- something to fix! Although it's also worth trying with the .ovr extension as well, that should try and update it regardless.

Reformatting the memory card could possibly be an issue as well, if it's not FAT or FAT32 it wont recognise it, although I believe it would come up with an error in this case. But worth checking.


It does seem really strange it was working, then adding a few files later, it's doing this. It really makes no sense.


I'll quite happily take a look at it for you if you'd like to send it back to me. Sorry for the inconvenience, it's really unusual to have any problems with these carts, and this isn't an issue I've come across before.

Link to comment
Share on other sites

  • 3 weeks later...

Quick update on this thread; sent my GameDrive to SainT who kindly agreed to look at it. They found that it was stuck on the update screen and was able to successfully apply the latest firmware which seems to have resolved the problem. I tried the same thing (and yes, did change the file extension ;)  ) but with no success.

@SainT can probably best describe what they did to resolve the problem.

I'm looking forward to getting my GameDrive back a binging on a load of Jag games.

Huge thanks to SainT for his awesome help 😎

  • Like 2
Link to comment
Share on other sites

I’m not quite sure what the issue was, but it was related to downloading the firmware. Or at least, I fixed the issue with the website which was giving the incorrect extension for the update file, downloaded the update, and it applied without issue.


So with any luck this issue will not arise again! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...