Jump to content

When it rains, it pours…


Recommended Posts

Really crappy retro computing days for me today…


First, I’ve decided to redo my retro office space. Needed a bit of cleanup and prepare a nice functional space for my TI setup, my Apple IIe Platinum that’ll be here soon and my C64/128. Now, for the TI, I still need a few thing for my PEB, but I hadn’t tested my new 99/4a computer yet. Well…. All that I get is a black screen. The TV detect an ntsc signal, but there’s no beep or picture. Oh well, it was cheap and untested. Maybe if someone as an old 99/4a with a crappy case and busted keyboard, but a functioning motherboard I’d be glad to take it of your hand. My case and keyboard are like new.


so, since this wasn’t going to work today, I moved to the C64/128. The 128 as a bad SID and I was sure I had a second one laying around in my part bin. I found it but the 128 had a 6581 originally and the Sid I’ve left is the 85xx variety which isn’t voltage compatible. No sweat, there are a few modern replacement available. The Swinsid is the most common, but it doesn’t support paddles. The armsid is good but it’s hard to come by. I went for the fpgasid from the kryoflux guys. It’s a sid on steroids, it can emulate 3 sid in fact. So that takes care of the C128…


The C64G was an eBay fraud… What was in the box isn’t what I ordered. The machine picture was a C64G but I received a brown case with a C64C keyboard with one of those cost reduce slim board. And it’s dead… It’s partly my fault, I should’ve researched more about the seller before hitting the buy now button.


Well, since the C128 was working I decided to test out the 1571 and 1541 that I’ve to see if everything was ok on that front. I’ve a PI1541 Zero edition on order, but in the meantime I could make some floppies and type a few basic program just for the fun of it. Well… The two 1571 had a hard life. One was used to archive about 2000 disk since I’ve got it and it was bought used. The other came un another untested lot and never ever worked right. Sadly, now both are dead. I had a bit more life from the 1541. That one at least recognized a disk and I was able to load a dir from a known working floppy. But when it came to formatting a disk the problems started. It took me 3 try with known good disk to go through the full formatting process, but then if I load and list the dir, instead of printing the number of block free, I get “print#block free”. If I type a few basic line and save to the disk, when I list the dir my basic prg uses 8335 block…. I think floppies have reached the end of the line in my house.


I didn’t even buy a drive for the Apple IIe Platinum the I just bought. I’ll get a floppyemu for it instead.


what a wasted day this one has been…

  • Like 1
  • Sad 2
Link to comment
Share on other sites

So… I worked on my 1571, trying to see if the alignment was off or if something on the board was out of specs, but it’s when I took the drive mechanism out of the case that I understood…. The 1571, just like the lever equipped 1541 were newtronic drive, which mean they suffer from the same rotting head problem. So there’s really no point in spending money trying to find a replacement since it won’t live long enough to be profitable. No wonder 90%+ of the 1541 and 1571 drives for sale on eBay are “powers on, untested”…

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...