Jump to content
IGNORED

GD FW first time install issue


Recommended Posts

Hi. Total noob to Jaguar GD (obvi after you read below)

 

Finally getting to install FW on my GD which I bought when AA first started selling them a few years ago now, so I have one of the first I believe with 3d Printed Case. Long story short, I had a few surgeries, deaths in the family and always said, "yeah, I'll get to it after all this calms down". Well, now that we're waiting for new games on AA still and it's cold out, I said to myself, "Now is the time for the Jaguar GD setup"! :) 

 

Background: my Jaguar works normally fine - I have a few OG carts and also Gravitic Mines from AA and enjoy them immensely! 

 

I followed the GD instructions first time I installed the cart into my Jag and downloaded my first time FW download from the QR code on the screen per instructions. I put it on a memory card (SanDisk 32Gb ultra microSDHC UHS-I formatted FAT32) and installed it into the GD case. For some reason I thought I needed to press Option during boot. I think I confused this with later upgrades needing to do this. Well, anyways, I pressed the option button during boot up, the cart's red light went on, then off. I let off the  option button and just see the Red Jaguar logo on the screen. No menu systems or anything. Turned off / on again, same thing - Jaguar logo. I'm pretty sure I screwed up. Is there any hope?

 

Please help :( 

Link to comment
Share on other sites

5 minutes ago, Kaboomer said:

the Red Jaguar logo on the screen.

This usually means something to do with a dirty cart or cart slot. Not 100% for sure, but I'd clean both really well at the very least.

Edited by Hastor
  • Like 1
Link to comment
Share on other sites

37 minutes ago, Hastor said:

This usually means something to do with a dirty cart or cart slot. Not 100% for sure, but I'd clean both really well at the very least.

Thanks Hastor for a response! 

 

1. So this has nothing to do with pressing Option while trying to install the FW the first time?

2. The cart was able to download the FW file onto it from my Mac, and the GD and Memory cards are brand spanking new, so not sure why it would not be clean?

3. How would you suggest to clean?

 

Appreciate any help you (or anyone) can give.

 

Thanks again. 

Link to comment
Share on other sites

So I did some cart and card cleaning with some Isopropyl and rebooted. No red Jag screen. :) 

The QR code comes up and it briefly says "Press option for firmware update". That message goes away then it says "Menu Error!" under it.  :(

This is both with or without the memory card installed.

 

Any help is much appreciated.

 

  • Like 1
Link to comment
Share on other sites

6 minutes ago, CyranoJ said:

If its one of the first batch you will probably need @SainT to help you with a new firmware.

Yep CyranoJ, it IS one of the first batch I believe. I still have my AA receipt dated 12/22/20.

 

This was at the time where one had to download and install FW from specific URL QR code first time.

 

Appreciate your help then @SainT

Link to comment
Share on other sites

I still get the "Menu Error!" when I boot up, but noticed a new QR code when I press option during boot up. I went to the QR codes' URL site and the message says:

 

"You currently have the latest version of the firmware available for the Jaguar Game Drive installed... There is nothing for you to do except enjoy playing old games"

 

So a bit more confused and not sure what to do next.

Link to comment
Share on other sites

At a guess the bad edge connector contact (the reason it ended up red screening) caused it to fail updating the menu correctly.

 

If you follow the link on the QR screen from pressing OPTION during boot (when it says "Press OPTION for firmware update") and grab the firmware here --

image.png.7c6331ed128782abb4b5255c64595085.png

 

Then put the firmware.ovr file on the root of a memory card and boot with that inserted, it should update everything. Once updated remove the firmware.ovr file, otherwise it will continue to update part of the firmware each time you boot.

Edited by SainT
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...