Jump to content

Updated GameDrive firmware but within the menu system it is reporting an old version.

Recommended Posts

OK so tonight i updated my game drive with the QR code for downloading the latest update, copied it to the memory card plugged it back in and booted up, the light on the game drive came on RED for a couple of seconds and went out.  then the screen stayed black. i waited a few minutes and the screen was still black.  i rebooted and the menu was shown, but pressing 0 for the version its telling me im on stub 1.04, looking on the update webpage this seems to be an old version.  the firmware is still on the memory card but doesn't activate any update procedure ob power on.


the GD appears to still work properly and loads roms.


would this be a bug or an issue i have caused?


Edited by omf
pictures added
Link to comment
Share on other sites

Odd. If the firmware.upd file is on the memory card when booting it should pick up on that and update the Jaguar side as well. But it’s also strange the Jag went to a black screen, as that’s not normal either.


Try it on a blank memory card with just the firmware.upd on there. I do have some recollection there have been issues if the card was quite full and the update file was at the end of the directory.


But either way, unless you are writing and uploading code to the Jag from your PC, the stub will not be used. That is purely for programming purposes.

Link to comment
Share on other sites

i seem to have fixed it with the top ovr file or v1.05 now which functioned as it should have originally. maybe i had excess dust on my contacts as i haven't used in a while


i might use the programming functionality in the future.


i take it these are both the same


Link to comment
Share on other sites

  • 2 weeks later...

I'm curious to know if this latest update did anything to improve JagCD compatibility..?

I ask because I've tried many (many) times in the past to play BattleMorph and have never made it through the menus without crashing.

Last night on a whim I tried the same ISO image with the updated firmware - and it worked great! 


I was playing BattleMorph for over an hour, the first time I've ever played the game. 

I even power-cycled the Jag and loaded it again to se if it was a one-time fluke, yet it worked fine on the second try as well.


Edited by ls650
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...