Jump to content
IGNORED

Atari Flashback 50th Anniversary Custom Firmware for USB roms and boxart


Recommended Posts

3 minutes ago, Brad_from_the_80s said:

I don't think I've ever heard of this issue.  I don't really support Nexus myself, but insofar as it can load very large numbers of games and/or some versions support cores that really weren't meant for the device, memory exhaustion or any number of other issues could be the culprit.  Would definitely test whether this still occurs without Nexus in place.  Nexus was also never technically updated for AFB50 as far as I know.  It works, but may be using a 2600 core from one of the previous devices.  They apparently can differ slightly.

Thanks very much. 2600 games hang too in Nexus. Takes about 10 min. and then freezes. Pretty much any game that I tested regardless which emulation.

 

Without Nexus the 2600 games work without any issues.

Link to comment
Share on other sites

Just wanted to post that I too have the issue that others have seen with the Nexus freezing up on the AFBG50.

I got the Nexus pure build off of Archive.org.

Using a high capacity samsung 3.1 usb jump drive and with Nexus it freezes up in almost every section that I go to and games freeze and having to hard reset and turn off.

Would love to see an updated Nexus build to work with the Atari Flashback Gold 50th Anniversary edition.

 

Thanks.

 

JDog2915

Link to comment
Share on other sites

On 3/16/2023 at 7:14 AM, rocketfan said:

If you are going straight to the IV folder from the "root" Nexus menu, then lfb should not really be involved.  When you say the box art shows up but the games don't launch, a similar problem woud be caused if the rom file names are not exactly matching the entries in all-games.ini.  This could be caused by the case (Linux is case sensitive) being different or a hidden extension.  Now I am talking about the all-games.ini and the game files in /rom_iv on your stick.  I guess it's possible if you build the thumb drive a certain way that the case or file names get munged on the rom files.  One time someone had added extensions because their OS (I think they were using a MAC) was hiding extensions they ended up with double extensions IIRC.  If you just unload the .rar archive directly to the root of your flash drive I don't see how that type of thing could happen, but it's worth a check.  Your flash drive should be formatted FAT32, btw.  If it's formatted to any other filesystem type your results are undefined to me.

 

Sometime soon I'll use your main all-games.ini on mine and see what happens - I suspect it will be fine, but worth a try.

 

There is another mechanism you could try to see if your results change.  First, make sure it's working.  When you turn on your system, WAIT until you see the atGames logo on the TV and then press and hold fire on joystick 1.  Instead of booting into the main Nexus menu, you should see the Atari Arcade games section has loaded.  If this works, launch a game and be sure everything is functioning correctly.

 

Now, shut down and edit the fie /emulator/fire  - this is a text file and should contain only rom_aarc.  Change it to rom_iv  Now when you press fire on boot you should boot straight to Intellivision - maybe (doubt it) your results will be different?

 

 

Finally figured out the problems the bios and the core were corrupted I got them working now but I need help getting controls. Can't pull up virtual pad. Can you help me @rocketfan

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Hello,

 

I'm in the process of trying to update my Flashback 50th Standard edition (3070) to the latest CFW V1.1.1. 

 

While I understand that the CFW 1.0.0 in this thread works on the 3070, the updated v1.1.1 CFW requires the official firmware update first. This doesn't exist for the 3070.

 

I'm planning to attempt to flash the original 3080 v1.1.1 firmware to the 3070 device and then apply the CFW v1.1.1 patch.

 

I was wondering if anyone has:

 

a) Successfully or unsuccessfully attempted this

 

b) Has a copy of the original 3070 firmware (AR3070_v0.0.5) in case things don't go to plan

 

Thanks in advance  

 

Link to comment
Share on other sites

I emailed AT Games and asked them if they could provide me a copy of the Stock Firmware for the AR3070 and they replied sending me an Image file the looked very much like the v1.1.1 firmware for the 3080. Sure enough, when I Flashed it, it turned my 3070 into a Gold Edition and the about section showed it was the latest 3080 Firmware. So I no longer require the 3070 Stock firmware and if anyone else is wondering, it appears the v1.1.1 firmware for the 3080 can be used to fix paddle issues (and add 20 more games) on the 3070. The latest CFW image also works when flashed on top of it. Probably likely the future updates would also work, but I guess there's always a small risk.

Edited by Simmo
Link to comment
Share on other sites

  • 2 weeks later...

I'm pretty sure the first firmware AT Games sent me was the 3080 v1.1.1 firmware from their website. I can confirm that worked on my 3070. When I queried it, the apologised and sent me a version of the 3070 firmware (AR3070B).  I haven't tried that one but I'm happy to share the files if allowed?

Link to comment
Share on other sites

I just flashed my Flashback 12 with the 1.1.1 custom firmware.  I put the mount_sd.ini on the root of my USB and only the ROM directory dumped to it.  I tried putting some other ROMs into the rom directory like Pac-Man, Ms Pac-Man and Raiders and put the USB drive back into the OTG cable and when I turned on my Flashback it only displayed a single white rectangle instead of all the game boxes.

 

I noticed the all_games.ini file in the ROM directory is an empty 0k file.  Should there be something in this so it knows where to find the files? Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...