Jump to content

no picture when cold start - missing -13VDC


Recommended Posts

Hi Vectrex experts,


I am Denis from Germany and I am a new Vectrex owner or better to say - I got the vec fever 😁


I hope there is somebody out there to help me out with this strange issue. Although i got no background in electronics I learned a lot in the last years by repairing a number of retro computers. Also difficult cases. After all these nice and interesting Commodore´s, Atari´s, Apple´s and IBM´s I have collected over 4 years I thought there could be nothing left which is even more exiting. Until I found my Vectrex.😘 I got it in a good condition although the calibration was far off. Tried to calibrate the unit but could not achieve a good result. So I decided to give myx vectrex a bit love and replaced all electrolytic and polystyrene capacitors. This went actually quite nicely without any issue. I made sure to replace them with the right type and put them in the right orientation. Double checked many times. But one issue happened to me though. I overseen that during the operation I bended C324 in such way that it got contact with the 5 VDC leg on the J204 connector when I put the plug on. I stupidly overseen it. So there was a short between +5VDC at the connector and the GND side of the capacitor. See photo attached.


When I tried to start up the vectrex the first time after the recap it did not start at all. Then I found that shortcut at J204 and fixed that. Maybe that caused my issue - I dont really know. But maybe not. Because since then the Unit always starts up and I can hear the sound from Mine Storm.

This tells me the logic is functioning. But there was no pcture coming up. Initially I thought the 6522 is the culprit because after replacing it the Vectrex worked as normal again. Furthermore I was able to calibrate it and now I got a very nice straight picture. But it only worked for 2 days or so. Then failed again. Sound but no picture.


This is still the current state. During troubleshooting I always found roughly 10 VAC at EP104 and EP106 (vs. EP105 or any GND contact). I always got -4,92VDC and +4,95VDC which looks good to me. But when there is no picture then -13VDC is missing. Actually I measure -30 mV or so. Now - when unplugging at J204 (-5V, +5V, GND, -13V from the Power supply) and starting up again I see -13VDC at the analog/power supply board. When plugging in at J204 again then I also get -13VDC at the digital board and I immediately get a picture on the screen. Like a magic self repair. 🤔 For 1-2 days only and then fails again. Believe it or not but starting the Power supply board when the digital board is disconnected and then reconnecting the digital board fixes temporarly the issue. Really strange. Because I espected a short between -13V and GND I already replaced all capacitors between -13VDC and GND one more time but without success. I replaced IC301 but no luck. It´s the only chip which uses the -13VDC. Also tested 2 different 6522 - same story. Looking on the schematic there are a number of diodes in the -13VDC circuit. Is there maybe a diode causing this temporarly issue? Can diodes fail in that way and then ressurect for a while?


Something prevents the power supply board to establish the -13VDC when the unit is not in use for a while. But it fixes somehow itself temporarly. Accidently i shorted -5VDC and GND when doing troubleshooting. This imediately brought back the -13VDC and the screen went on. Strange. I am really getting crazy about this issue.


Is there anybody having an idea what could cause my issue here?


I appreciate any little suggestion 😊



best regards



Link to comment
Share on other sites

It will be the power switch. One pole of the switch can fail while the other is working (which is why the logic board works). Periodically it will work when the connection is good (sometimes after warming up slightly).


Take the switch apart & clean (harder than it sounds) or a quick 'fix' is to bypass the power switch entirely.

Link to comment
Share on other sites

Thanks for helping me. But I am sure the switch is not causing the problem. When I recapped the system I also did clean up the switch and when turned on I can always measure continuity. When the unit (screen working or not) is on I can always measure ca. 10 VAC at EP104 and EP106 which tells me the switch is ok.


Yesterday I replaced D106, D107 and DZ102. Then I turned the unit on and let it run several hours without no problem. Then suddenly (in the middle of playing Vectorblade) the vectors got scrambled. It’s still the case also after replacing the 6522. Looks like now I got another fault🥵


There is currently no chance to get the screen up and running again. I can hear the sound of mine storm though.



Link to comment
Share on other sites

  • 2 weeks later...

Obviously replacing the Diods helped to fix my missing -13VDC. Since then the screen always starts. Meanwhile I was also able to fix the vector issues. It has been caused by a faulty IC302. Maybe this chip contributed also to the other issue? I don’t know. I was nearly giving up but with some great help in the VCFED Vintage Gaming Forum I finally got my Vectrex up and running again 😊

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...