Jump to content
IGNORED

Finally got a F18A, FinalGROM 99 failing to load many games now.


Recommended Posts

Hey all! After waiting for a F18A for a long time I finally got my hands on one. Install went well, and powering on the computer I now get a crystal clear image!

However, I'm noticing a lot of things seem to be not working now. I use a FinalGROM 99 cartridge and I had it pre-loaded up with Super TI99 Mario Bros. Usually, before having the F18A when launching this I'd get a blank screen with the music from the game playing. Now after installing my F18A, I get nothing but a cyan screen.  Some other games do work still, I tried alpiner which ran fine. Is there any known compatibility issues with the FinalGROM 99 and F18A?

Link to comment
Share on other sites

The F18A works with all software that is written for the TMS99(18|28|29)A, so if you have issues like those you describe, something is not OK with your unit.  I'd check whether it is installed correctly in the socket.  If it is, then you'll probably have to return it for repair. :(

  • Like 1
Link to comment
Share on other sites

51 minutes ago, Hans23 said:

The F18A works with all software that is written for the TMS99(18|28|29)A, so if you have issues like those you describe, something is not OK with your unit.  I'd check whether it is installed correctly in the socket.  If it is, then you'll probably have to return it for repair. :(

Dang 😕 I'll have to dig in and confirm my FinalGROM99 isnt behaving incorrectly. It had been awhile since I used it prior to installing this. Both of the more graphically impressive things I tried (the TI-99 Homebrew Demo, and Super Mario Bros, both just stopped at a cyan screen. Only older games like alpiner, etc seem to work.

5 minutes ago, InsaneMultitasker said:

This probably isn't the issue but I'll ask anyway... is the F18A firmware current?

Looks like mine is on v1.9

Link to comment
Share on other sites

My F18 console with FG acts up sometimes too.  After the unit heats up,good to go.  I read something similar before and about the FG might require more power than a regular cartridge so clean contacts are a must to make up for any gunk that could have a power reducing insulating effect.  Arcadeshopper made a good observation about 32K expansion do you have one onboard?

  • Like 3
Link to comment
Share on other sites

14 hours ago, arcadeshopper said:

i assume you have 32k for the program?

 

 

Oh my God. This is it. I was so far removed from the setup by the time the f18a arrived I forgot that I needed my TiPi/32k sidecar for more than just the TiPi itself! I didn't plug that all back in while testing. Just the system and FinalGROM99. Out of town now but I'm positive this is the answer. Thank you!

  • Like 4
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...