Jump to content
IGNORED

Altirra64: starting .xex file?


Recommended Posts

Default is to save settings in registry, you have to change this to save the settings to a file,

make a copy of the file, make your changes, then to recover, just use the saved copy.

 

In Altirra, go to Tools-> Options, then select "Settings" the switch is there to select File or Registry settings.

Link to comment
Share on other sites

There's nothing special about .XEX files, they are just normal executable files normally run from

some version of DOS, although you can run them directly from some of the modern cartridges.

 

In a nutshell if they are not running there's something wrong with your setup. 

Link to comment
Share on other sites

Had a look at your .XEX file, if your using DOS of any kind, this won't run, it will be overwriting DOS files

please see below where the code is loaded:-

 

Segment  1: Load:0900 End:0C9A Size:039B
Segment  2: Load:0CA0 End:0E85 Size:01E6
Segment  3: Load:0EF0 End:12F4 Size:0405
Segment  4: Load:1300 End:17CA Size:04CB
Segment  5: Load:1800 End:1FD1 Size:07D2
Segment  6: Load:2000 End:3C6F Size:1C70
Segment  7: Load:3C80 End:7C39 Size:3FBA
Segment  8: Load:7D82 End:7DBF Size:003E
Segment  9: Load:7E00 End:7EBF Size:00C0
Segment 10: Load:7F00 End:8323 Size:0424
Segment 11: Load:8400 End:971F Size:1320
Segment 12: Load:9800 End:9BEF Size:03F0
Segment 13: Load:9C00 End:9FFF Size:0400
Segment 14: Load:02E0 End:02E1 Run:2000

Link to comment
Share on other sites

Guess you have 400/800 mode activated in Altirra (the mentioned memopad mode is from these computers) and thats why the program does not run ? Or you activated (only) 16k RAM and therefore the program does not run ? 

 

I suggest to setup Altirra for XL-OS Revision 2 and somewhere between 128K and 1088K RAM. This should load most XEX programs. Last not least, the option for Basic on/off in Altirra is not always easy to understand (no clue why it does not simply say Basic on/enabled -or- Basic off/disabled), most XEX files will only work with Basic off/disabled.

 

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...