Jump to content

IDE v3 Prototype and Pre-order link online


Recommended Posts

2 hours ago, Shift838 said:

I asked their very exact question to Fred before I started down this path for the through-hole design.  He told me it would be a lot of work to work on the DSR to get it loaded into an EPROM.  Since the DSR is so simple to load and literally loads in a few seconds (I use the BIN file on my FG99 to load the DSR), Fred nor I could see the benefit to spend that much time to recode the DSR to get it to work on a EPROM.

That is okay; I was just curious.  Sounds like the DSR uses the RAM for data-storage or, maybe, work-space.


Link to comment
Share on other sites

Looks like my IC supplier I ordered my components from, specifically the hexadecimal rotary switch, accidentally pulled a few of the wrong ones, although they look the identical, pin #1 is in a different location and will not work.  They have been contacted and new ones should arrive Monday or Tuesday.


Orders 71 and 72 will not be able to be completed until then.





  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
On 1/6/2024 at 1:39 PM, F.G. Kaal said:

Received my IDE card and components yesterday evening.

The IDE PCB looks great 🙂

Now I must spent some time assembling this board.



Assembled the IDE card, checked all +5V and GND connections and placed all the chips in their sockets.

Time to test this card ... problems with my system. Didn't want to startup. Problem was my HDX card which had a corrupted DSR (that was a long time ago this happens). After reloading the HDX DSR my TI99/4A system worked fine again. I needed the HDX connection for loading the IDE test program and DSR.


Placed the new IDE card in my PEB and started the IDE TEST program.

Front LED could be switched on and off.

Back LED could not be switched on and of ... now what, maybe wrong orientation, sort that out later ... proceed anyway ... can not write to DSR RAM. Something is seriously wrong here.

After some investigation I found that the selection switch at the back of the card was in the off position (duh). On the bright side this is also a good test ... that switch on the back did it's job.


Moved the switch to the TI position. Front LED and back LED could be switched on and off but the IDE test program still could not write to the DSR RAM. Now what! Also for this test I had placed the voltage regulator on the card although my test PEB is equipped with a 5V/12V/-12V switching power supply.

Seems that for this card the +5V of my power supply is not enough. I suppose that the voltage left at the output of the voltage regulator is to little for the clock chip to enable the RAM chip. After disabling the voltage regulator on the IDE card the IDE test program finished with no errors. Could also load the latest IDE DSR with no problem so everything seems to work fine.


Thank you again Chris for this beautiful designed IDE card.



  • Like 7
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...
  • 1 month later...

So I finally got my IDE board assembled and it seems to work fine, but it is refusing to properly partition the 3 different CF cards I tried. The cards are recognized and go through the partitioning and initialization process in DU2K without errors, but when I check they are still reporting as unpartitioned. What gives? Am I missing something here or is the board very particular about certain CF cards? I tried 2 256MB cards and a 2GB one with similar results. All known working in other devices. I even tried 3 different CF-IDE adapters with no change.

Link to comment
Share on other sites

I suspected an issue with the DATA lines of the IDE connector, and eventually traced back the problem to IC's 6 and 7 which were not seated properly with one side of the chips not fully inserted (machine sockets can be tricky). Once the chips were reseated the problem went away. FYI in case someone runs into a similar situation.

  • Like 3
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...