Jump to content
IGNORED

Atari 2600 related test results (not 7800!)


Thomas Jentzsch

Recommended Posts

On 11/22/2023 at 12:21 PM, chad5200 said:

Coleco Donkey Kong Junior.  NTSC.

 

Does not work for me.

 

(Tested great on a real 2600.  Contacts nice and cleaned.)

 

This is one that is "Passed" according to the official list. 

 

Anyone else have luck with this game?

 

I have a Coleco DK Jr that I am struggling to get to work, too. Any luck with it? I have cleaned it with contact cleaner a few times but no joy. 

E71C478E-CA4E-41F3-A292-B0C4CB334964_4_5005_c.jpeg

Link to comment
Share on other sites

21 hours ago, DEANJIMMY said:

Or one which fails on the 2600+ only.

I have got very few carts which work on old hardware but not on the 2600+

If it is destinated for the 2600+ only, you could also consider to get an NTSC cart.

In the past in Germany you randomly got NTSC carts for low price and were unhappy it's not PAL...

Now I would prefer for my 2600+ an NTSC version but shipping from US is expensive, takes extended time and you might have to show up at the customs....

I will see what I can get off Ebay. With the 2600+ PAL vs NTSC does not matter anymore and I still have a additonal Stargate which runs on original hardware. I might even wait to see if maybe the coming firmware update might fix anything. In the meantime I still got the original Defender to play ... so I am not without options.

  • Like 1
Link to comment
Share on other sites

On 11/25/2023 at 8:18 AM, DEANJIMMY said:

Tested some 2600 homebrews, all PAL or PAL60

 

Marble Craze, Medieval Mayham, Gunfight, Seawolf and Pac Man 4k work fine.

 

Fall Down, Conquest of Mars, Lead fail to load.

 

Space Instigators works but graphics are a bit corrupted (see Game Over text in pic) so you sometimes die without cause.

 

Thrust+

Failed controls.

Fire is pressed all the time, unplayable, graphics look great as always.

Nothing is plugged in, not even an evil extension cable 

And the driving controller might fail as reported from Indy 500?

 

Brix

Failed controls, can't start the game.

 

 

20231125_141607.jpg

There STILL isn't a version of space invaders on the 2600 I like. I want something much closer to the taito arcade version, and I feel like it's possible. Space Instigators is just not that. 

Link to comment
Share on other sites

8 hours ago, John Stamos Mullet said:

Here's some oddball results:

 

Space Shuttle and Decathlon work!

 

Robot Tank, does not. (rolling corrupted HUD like others)

This would mean your Space Shuttle and Decathlon carts most likely use F8 bankswitching. And Robot Tank uses FE.

 

@Rom Hunter There is no F8 dump of Decathlon in your ROM collection, but it looks like it exists.

Link to comment
Share on other sites

7 hours ago, Thomas Jentzsch said:

This would mean your Space Shuttle and Decathlon carts most likely use F8 bankswitching. And Robot Tank uses FE.

 

@Rom Hunter There is no F8 dump of Decathlon in your ROM collection, but it looks like it exists.

If someone needs to borrow my copy of Decathlon for dumping/testing I’d be willing to lend it out, provided it gets back safe. 

Link to comment
Share on other sites

8 hours ago, Thomas Jentzsch said:

This would mean your Space Shuttle and Decathlon carts most likely use F8 bankswitching. And Robot Tank uses FE.

 

@Rom Hunter There is no F8 dump of Decathlon in your ROM collection, but it looks like it exists.

That's interesting.

If somebody can dump it, please let me know.

8)

Link to comment
Share on other sites

I found a loose Beamrider relatively cheap.  It looked to be in good condition, except somebody had punched the label exposing the screws and maybe opened it?  It's very clean, and it definitely does work, but has turned out to be the most temperamental cart I have.  At first it would not load at all until I discovered it would if I pushed up to lean it forward a bit and held it there.  The board is ever so slightly loose in the case.  I opened it and re-seated the board and tightened down the screws pretty hard, and I can get it to work with 2-3 tries usually.  I've read about some of these Activision carts having issues anyway, so I don't know if that's it or it's really just this one cart or its case.  I have some other Activision and only one of them is a little finicky once in a while, but not like this one.

Link to comment
Share on other sites

In my onging mission to purchase an avalanche of old games I received Pick & Pile in the post today. When loaded it flickers like crazy in the menu and then when you start the game it is also misaligned on the screen. Again this is on the tested list, but I am using the PAL version here.

Link to comment
Share on other sites

On 11/29/2023 at 3:40 AM, Thomas Jentzsch said:

This would mean your Space Shuttle and Decathlon carts most likely use F8 bankswitching. And Robot Tank uses FE.

 

My Space Shuttle and Decathalon carts that work on the 2600+ are FE, I just dumped them..  (MD5)

 

525f2dfc8b21b0186cff2568e0509bfc *decath.FE.bin
898143773824663efe88d0a3a0bb1ba4 *shuttle.FE.bin

 

Link to comment
Share on other sites

19 hours ago, Brad_from_the_80s said:

I found a loose Beamrider relatively cheap.  It looked to be in good condition, except somebody had punched the label exposing the screws and maybe opened it?  It's very clean, and it definitely does work, but has turned out to be the most temperamental cart I have.  At first it would not load at all until I discovered it would if I pushed up to lean it forward a bit and held it there.  The board is ever so slightly loose in the case.  I opened it and re-seated the board and tightened down the screws pretty hard, and I can get it to work with 2-3 tries usually.  I've read about some of these Activision carts having issues anyway, so I don't know if that's it or it's really just this one cart or its case.  I have some other Activision and only one of them is a little finicky once in a while, but not like this one.

A lot of the later Activision carts used a thinner PCB board that originals, and even real 2600s and 7800s have difficulty reading them. Cheap design cost savings in post-crash Atari gaming.

  • Like 1
Link to comment
Share on other sites

45 minutes ago, remowilliams said:

 

My Space Shuttle and Decathalon carts that work on the 2600+ are FE, I just dumped them..  (MD5)

 

525f2dfc8b21b0186cff2568e0509bfc *decath.FE.bin
898143773824663efe88d0a3a0bb1ba4 *shuttle.FE.bin

 

Hm, then something else must fail. Can you try the dumps in Stella (without the FE), please?

  • Are the detected as FE?
  • Are they detected as known? 
  • If not, could you send them to me?
Link to comment
Share on other sites

On 11/24/2023 at 12:02 AM, Albert said:

I'm curious what you mean by no luck?  Do they not work at all?  Are you trying them with 2600 or 7800 games (or both?)

 

Thanks,

 

 ..Al

I tested two original three-button Genesis (Mega Drive) pads.

 

7800 game (Planet Smasher): D-pad works, buttons don't

2600 game (Demon Attack): Neither d-pad nor buttons do anything.

 

With the Mega 7800 adapter, the pad works with both games.

Edited by kimchipenguin
Link to comment
Share on other sites

1 hour ago, Thomas Jentzsch said:

Hm, then something else must fail. Can you try the dumps in Stella (without the FE), please?

  • Are the detected as FE?
  • Are they detected as known? 
  • If not, could you send them to me?

Yes, Stella detects the dumps as FE (named as <game>.bin).  They run in Stella as expected.

 

To eliminate any possible confusion - these dumps are not from the 2600+ itself, I have not yet modified it.

 

image.thumb.png.d46a959dc4598dcfef9389b930c009d1.png

  • Thanks 1
Link to comment
Share on other sites

On 11/29/2023 at 8:36 AM, chad5200 said:

No luck here.  Has anyone else gotten white shelled Coleco Donkey Kong Junior to work?

Just heard back on Reddit and that guy was able to get his Coleco DK Jr to work...so hopefully just a cleaning issue. Gives me hope I can get mine going eventually. time to break out the contact cleaner again. 

Link to comment
Share on other sites

1 hour ago, remowilliams said:

Yes, Stella detects the dumps as FE (named as <game>.bin).  They run as expected.

 

To eliminate any possible confusion - these dumps are not from the 2600+ itself, I have not yet modified it.

 

image.thumb.png.d46a959dc4598dcfef9389b930c009d1.png

The ROM is definitely known to Stella. And the bankswitching is auto detected by Stella (not stored in properties).

 

Since many people reported failures, I suppose these are resulting from cart contact problems.

Link to comment
Share on other sites

7 minutes ago, remowilliams said:

I wonder why FE Decathalon and FE Space Shuttle run on the 2600+ but FE Robot Tank does not

I think it's worth pointing out that Robot Tank does actually "load"... it's just the screen is all wrong and scrolling.  It is NOT like other failed games where the 2600+ reports "Loading Game Failed" and you get nothing.

 

Link to comment
Share on other sites

2 minutes ago, Thomas Jentzsch said:

What's the MD5?

 

4f618c2429138e0280969193ed6c107e *robot.bin

 

17 minutes ago, Thomas Jentzsch said:

Yes, it looks like only 4K are being dumped.

 

I see that running the first half of the FE Robot Tank dump in Stella results in a rolling 'Switching to Reserve Tank'

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...