Jump to content

Team Pixelboy News Bulletin - December 25th 2023


Recommended Posts

8 minutes ago, Kamshaft said:

I know that, but at this point I don't know what's causing it.  Did you try another game and try downloading the manual?

I tried several manuals within the homebrew list and I'm getting a 404 on every one.


But then I tried xdurable's suggestion and it worked for me.



Link to comment
Share on other sites

I played this game on the Atari 2600 when it first came out.


I put the cartridge in, I tried it out for 5 minutes then I went back to pitfall.

Games should not be this complicated.


Hats off to anyone that finds Space Shuttle not only fun but able to complete.

Your a better gamer than I.

Edited by Captain Cozmos
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...