Jump to content
IGNORED

Backbone One for iPhone, PocketGo-S30, Commodore VIC-20 - no characters displayed


Recommended Posts

I have a VIC-20 that doesn’t show characters. It used to show them once the computer warmed up, albeit still not perfectly. 
 

Now it just shows the cursor. The cursor does move as I type. 

Pin Ball cartridge is included as well as a power supply and RF box. I also have a C64 guide to throw in, if interested. 
 

Asking $40 plus shipping from 32765

 

IMG_0989.jpeg

IMG_0985.jpeg

IMG_0983.jpeg

IMG_0982.jpeg
 

Edit:

 

I’m also selling a Backbone One controller for iPhone. I replaced my iPhone with a new one that uses USB-C so I can’t use the controller with it. Comes working and in the box. Asking $50 shipped to US

 

Also selling a PocketGo-S30 handheld emulator. It works well I just don’t play with it these days. Asking $50 shipped to US

IMG_1039.jpeg

IMG_1040.jpeg

Edited by flashbackmatt
Reduce price, add other items
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...