Jump to content
IGNORED

Mapping controller for NES/SNES games with Gamestation Pro?


Gabe

Recommended Posts

Posted (edited)

I do have the controller, but nothing works properly. The Start button makes the character move left, and the X and Y buttons work for an in game menu, but are backwards. None of the other buttons, including the D pad, do anything.

 

For reference, the controller itself is fine. It works with NES and SNES games with RetroPie with my Raspberry Pi, and it tests correctly on controller testing websites with Windows.  

Edited by Gabe
Link to comment
Share on other sites

19 hours ago, Atari8264 said:

I don't have the controller and have not seen anyone else say they tried it.  Did you try to hold the X button button when you plug it into the console to pit it in X mode? 

I hadn't tried that, but after doing so it didn't seem to make any difference. I also tried a Logitech F310, and though it was messed up as well, the left mini stick did work for directional movement. 

Link to comment
Share on other sites

Eek. While I was again unsuccessfully trying the controller with a couple of SNES games, both being RPGs, I noticed that the music started slowing down, indicating something wasn't running right with them. It did it with both games (Final Fantasy IV and The Legend of Zelda: A Link to the Past). 

 

I think I'll just stick with my Raspberry Pi for the NES and SNES games. Thank you for the help though. It's very appreciated.

Link to comment
Share on other sites

  • 2 months later...
Posted (edited)

The AGSP uses the Retroarch.cfg file to set up its buttion so has one for each game or each emulator in the GUI so to get another controller or joysticks to work you would have to change its input settings in it or try and get autoconfig to work instead, not sure if it does work, no it don't, it uses the button in the config file, if you look at this image:
image.thumb.png.60ee57a1a3dc41da414d5f40be1f5be3.png
You can see the a2600.cfg file input buttons are different to the a5200.cfg file, its numbers to the buttons are different.
Like: 

input_player1_r_btn = "304"

is not the same input as:
 

input_player1_r_btn = "313"

AGSP does not support another Joysticks, only the one it comes with so you will have problems with using another controller or joystick plugged into it because it does not use Autoconfig in Retroarch.

Edited by Spanner
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...