Jump to content
IGNORED

QI model schematics


Recommended Posts

6 hours ago, JJB said:

@OLD CS1 I remember you mentioned that particular console was already a bit icky and you would test further; did you in the end?

It wound up being the FG99.  I have two: one works with the new firmware, one does not.

Link to comment
Share on other sites

1 hour ago, Tursi said:

I wonder, could it have been to make the GRAM Kracker stop working correctly? If you can't inject data overtop of the bus anymore, seems that would prevent it.

 

 

I doubt it. The GK was not popular product and came late in the ti99 history of console production.

 

QI focus was all about reducing costs and improving quality and reducing the number of warranty returns. TI already went through two customer lawsuits over the external power supply brick forcing them to replace all the wall hung ones and then again with fuse added ones. And warranty side was having issues with a number of returns and finally when TI went to government and asked for tax write down to pull out of production there was requirements to have enough inventory on to cover a few years of warranty replacements. The QI continued to be manufactured for over a year after sales shutdown to build up that stock of warranty replacements units in case they were needed.

Edited by Gary from OPA
Link to comment
Share on other sites

11 minutes ago, Gary from OPA said:

The QI continued to be manufactured for over a year after sales shutdown to build up that stock of warranty replacements units in case they were needed.

And then flood the market after all warranty periods had expired?  Do we know how many were manufactured after that, and how many missed the skip?

Link to comment
Share on other sites

1 hour ago, OLD CS1 said:

And then flood the market after all warranty periods had expired?  Do we know how many were manufactured after that, and how many missed the skip?

Not sure. They did continue to sell off units in South America for a while after sales stopped in North America. I had a chance to at one time buy up the inventory at the Canadian warehouse in Markham after geo services wanted to empty out their warehouse I went there in the late 80s got a complete inventory list and was working out the financial details but sadly my NIT corporation investors out voted me at the board meeting, I never found out what happened to all that Canadian inventory if they found another buyer in America for it or stored it somewhere else instead of just scrapped it in the end.

  • Sad 1
Link to comment
Share on other sites

10 hours ago, Gary from OPA said:

I never found out what happened to all that Canadian inventory if they found another buyer in America for it or stored it somewhere else instead of just scrapped it in the end.

About two decades ago, a stash of Commodore CD32s were found in a warehouse.  Someone got hold of them and put them up on eBay.  I picked up two for $69 each.  Would be pretty cool to see such a find of 99/4A consoles (not disregarding the Deihn's Hardware find of accessories and software.)

  • Like 1
Link to comment
Share on other sites

On 3/27/2024 at 11:14 PM, OLD CS1 said:

Yup.  Just put the firmware files on the SD card.

 

https://endlos99.github.io/finalgrom99/

i finally got around to trying out the update files on sdcard for my FG99 on my QI console.

 

there is two files one for PLD and one for AVR.

 

I copied the version_qi.pld to SDCARD and renamed it to UPDATE.PLD and that worked it updated the PLD without errors, and now the "finalgrom99" appears on QI console.

 

but the verision_qi.avr to SDCARD and renamed as UPDATE.AVR doesn't do anything, all I get is fast blinking light on the FG99, is there any way for it to update the AVR?

 

As its not perfect on QI console still with just PLD update, the menu appears but when you select like A or B or C for one of sub-directories on the sdcard, nothing happens it just locks up, does not display what files are on the sdcard when on QI console.

 

but on normal /4a console, the FG99 still works perfectly, the menu fully works.

 

Weird. i tried two sdcards, and naming the version_qi.avr as UPDATE.avr and update.avr and UPDATE.AVR and nothing, on both /4a console or QI console it just fast blinking light, as if it doesn't like the update file.

 

oh'well, at least it is halfway there, i now at least get a FG99 menu on QI, just can't load any carts from the menu.

Link to comment
Share on other sites

oh'well.. i guess I can't update the AVR on my FG99 -- I tried two different SDCARDs, both work perfectly for carts but for the UPDATE.AVR - One just blinks on then off, slowly and the other just blinks rapidly. -- I can't update to QI AVR or even reload the v1.3 -- Updating the PLD works fine, but that only solves have the battle. -- I guess the next step to open up my FG99 and see if the pin header is there for ext. cable programmer update, and build a cable and try that way.

Link to comment
Share on other sites

I had a similar issue once. Than I caught myself renaming the file wrongly, to something like UPGRADE.....:roll:

 

Have you tried reformatting the SD card? I've had an issue with an upgrade mod. of my own. Where about 10/20%, of the times that i eject the card from my Win10 laptop, some unknown carryover causes my mod. to fail. It has been suggested that perhaps sometimes a flag might get set, that takes the card out of Quad-Serial mode. On occasion, I've had to off-load the files, reformat, recopy files, ...fail... try again, a few times in a row!

Link to comment
Share on other sites

2 hours ago, chue said:

Try a different, preferably non-QI console?

My fg99 works great on my normal consoles, but I was trying to update the firmware with the version_qi that was released which reported to have good results.

 

Problem is my fg99 only updates the pld part. Any attempts to update the avr part fails, I tried a few different sdcards and all 3 of my consoles, and when updating the avr I either get a rapidly blinking light or a led that briefly blinks once a second.

Edited by Gary from OPA
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...