Jump to content
IGNORED

Jag stopped working today (power led lights but screen is blank)


Recommended Posts

I was testing my Jaguar today with a jag2gen, retrovision cables, ossc, into my 4k monitor this afternoon and was very happy to see it was working. I had rebooteroids plugged in at first and then changed to the rebooted cart and played a little downfall. I turned everything off to move things around and when I connected it all back up and turn it on, the power led would light but the screen stayed black, no Jaguar logo, no red screen, just blackness. I also tried composite output and a separate power supply and still a black screen. I tried just now again with composite and black screen as I was typing this post and black screen. Pulled the cart and reinserted and hit the power button and this time the rebooted cart came up. I pulled that cart and plugged in the gamedrive and turned it on and the gamedrive put up a menu "Cart Connection Fault Please remove, clean, and reinsert the GameDrive cart." I'm sure my cart is clean, and the rebooted and rebooteroids carts are new. Any idea what is going on? Is my cart connector damaged? I looked with a lighted magnifying glass but couldn't see anything obvious. Do I have dirty contacts on my cart connector or maybe something in the electronics of the console is going bad and causing the GameDrive to think it's a cart connection issue?

Link to comment
Share on other sites

Could it bad solder joint on the cartridge connector?

I would initially suspect the cartridge power pins bacause...

  1. The Jaguar powers so it is not the GND cartridge pass through
  2. If it was an address/data line issue would that not result in wrong check sum being returned resulting in the RSOD instead of a Black screen?
  3. If the cartridge is not getting power then it could potnatially be loading the data/address lines, protentially killing data activity on the data/address lines thus preventing any kind of operation. 
Link to comment
Share on other sites

Ok so I cleaned the contacts by making 10 insertions with a cutup creditcard wrapped with a Kimwipe soaked in 100% isopropyl alcohol. The wipe remained clean looking. I plugged in 4 different carts, one of them being the GameDrive and the Jaguar started up normally each time so here's hoping the problem is now solved. 

  • Like 5
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...