Jump to content

Create Your Own Adventure! - Final Version Released

Atarius Maximus

Recommended Posts

Downloaded V0.26 and I got a run-time error:  


"Run Time error 339:  


Component MSCOMCTL.OCX or one of its dependencies not correctly registered; A file is missing or invalid"  


Something I did? I'd like to check out the program.


No, you didn't do anything wrong. Your PC likely doesn't have that particular OCX file installed & registered. The easy fix would be for me to create a setup.exe install package and include the runtime files, rather than just providing the application executable file only. That should allow it to run on any PC. I'll do that with my next build, but with a disclaimer. Running a setup file will copy system files and modify your registry, and while it should work just fine, use it at your own risk. ;)


I'll make a setup package available later tonight or tomorrow.

Link to comment
Share on other sites

Cool. I'd like to get into hacking games but I'm not sure if I could figure it out or not.  


I've used Hack O Matic 2 in the past.


This program will definitely make it easy to figure out. :)


By the way, are you using Windows XP Home Edition? Just Curious. That's what my dad is using, and I downloaded it on his PC and got the same error. I've successfully run it on XP Professional and 2000 Workstation without having to copy any OCX files.

Link to comment
Share on other sites

XP Professional here.


Well, I guess that blows my theory about it being related to the OS Version. The necessary files must be installed by some other unknown application, which is why it's worked on all of the PC's I've tested without running a setup package.


I compiled the latest version this evening. I didn't finish up on the Invisible Maze options, but I wanted to get a version out that Kepone could try out. :) I set up this version as an install package, which will install all of the dependency files that the application requires. If launching the executable file works for you, there is no need to download and use the setup package. Also, once you install the setup package, there will be no need to do it again, just download the exe only and copy over the old one when new versions are released. The dependency files won't be changing.


From here on out, I will release each new revision both ways, as just the exe, and as the setup package. To install the app, just download the zip file, unzip it into a temporary directory, and launch setup.exe. Just follow the prompts from there, the only option given to you is to change the path that it installs to (the default I chose is C:Program FilesCYOA).


For those that might want to know, the Install Packager identified the following files as dependency files, and they will be installed when you run the setup program:








The file is too large to include as an attachment, so I put it on my website to download. You can download it here: http://www.steveengelhardt.com/cyoa027.zip (5.60 MB)


This new version (0.27) is sort of an interim release, it has one new feature that is not fully implemented yet. It Includes the ability to change the Blue Maze and the White Castle Maze to be invisible. Because the feature is unfinished, if you save your files, the invisibility option will NOT be included in the save file. I of course will change that in the next release...It's only two checkboxes. Also, I did not test the new feature fully. I know it changes the blue maze to invisible correctly, but I have not checked to see if it changes the Red maze successfully.


Link to comment
Share on other sites



What more is their to say? This is spectacular :D


It makes me sick to even look at my old Vader-Matic after seeing this work of art. Great job.


BTW, I hope you don't mind, I took some liberty with your code.

If you don't like this, I'll remove it.


I know VB is great for making programs easily, but it completely lacks any and all forms of efficency when it comes to speed and size.

I almost gasped when I saw 10+ Mb to edit a 4 Kb file...

So, I RE'd the tool, compressed the graphics, repacked the tables, threw in a few minor XP tweaks (that should not effect the tool in other OS's), rebundled it all, and here you have it, your CYOA at less then 10% of its original size.


Please RENAME to .ZIP and extract...

for whatever reason, it kept telling me I can't upload a zipped file :/


Doh! Timing... already, 27 is out, and looks to be a lot smaller.

I'll look into it.

Link to comment
Share on other sites

Well, took a look, and sure enough, 10+ Mb, so did it again.

Also found out, if a file is too large for this forum, it gives a false reason for rejecting the file... as such, I'll post it here for now:




622 Kb


If Maximus doesn't mind this, and my bandwidth isn't killed, I'll leave it 'til the next update.


corrected typo in URL


File removed for newer update below...

Link to comment
Share on other sites

If Maximus doesn't mind this, and my bandwidth isn't killed, I'll leave it 'til the next update.


No, I don't mind at all. I'd love to know exactly how you did that. If you could give me a good explanation, I'll do it myself on each release, otherwise, feel free to keep optimizing the exe on each release for me!


I played around with the app a little more last night, and the checkbox for changing the blue maze and white castle maze to invisible does indeed work perfectly. I noticed one more thing I want to change, when you are on the world map and you click on a map screen, it gives the minimized window focus, but doesn't pop it up and return it to its normal state. I'll change that.


Also, on the Color Change screen, if you add invisibility to a room, and then click on Load default values, it changes the color from $08 back to the default. That's no good, it has to be $08 for it to work. I'll fix that problem too.


There's one more issue I noticed, and I can't remember if I already mentioned it earlier or not. When you select the path to dasm, there cannot be any spaces in the path name. When it runs the command line tool, the space throws it off. I'll see what I can do to fix that too.


Thanks for all the compliments Greg, I'm glad you're enjoying it. I look forward to people posting some new Hacks (and hopefully the save files too!). If anyone wants to volunteer, I can include some sample save files along with the final distribution, that is, if I ever actually finish working on this! I keep thinking of more things to add. :)

Link to comment
Share on other sites

A new version is ready.


Changes in v0.28:


:arrow: You can now change all of the map rooms to invisible with the following exceptions:

-----Castles: If they're invisible, you can't tell what color they are.

-----Level Select (Number) Room: Not used in gameplay.

:arrow: Invisible Room options will now be saved when you hoose "File"/"Save".

:arrow: World Map will now restore each window to a normal state when you click on one.


Download Link for full setup package: http://www.steveengelhardt.com/cyoa028.zip


Greg, if you want to optimize the executable and re-post it, feel free! :)


Link to comment
Share on other sites

Well, I could tell ya how I did it, but then I'd have to kill ya!


No, not really... but I am using a few, shall we say, not so mainstream tools.

Especially to RE the thing... of course, you don't have that issue ;)


But to make things simple, here's the next one:


578 Kb


link removed for update below

Link to comment
Share on other sites

As crushing this program takes me a good hour to do after I see a new update, I'd like to know if others are interested in this modification...


Does size really matter? :D


For Atari programmers, I'd think so... 93% wasted space...

could you imagine if PacMan could have 93% more space for coding...

Oh well, just some flighty thoughts.

Link to comment
Share on other sites

Thanks Greg. Not so mainstream, huh? :D That's fine, as long as you don't mind compressing the releases for me and posting them. I'd certainly appreciate it.


I was thinking a little more about another big change, and I think it's going to be necessary. I'd like to add the ability to change the room location of each object, and the X,Y placement of it. It's easy to spot in the code:


;Object locations (room and coordinate) for Games 02 and 03.                  

     .byte $15,$51,$12        ;Black Dot (Room,X,Y)   

     .byte $14,$50,$20,$A0,$00;Red Dragon (Room,X,Y,Movement,State)         

     .byte $19,$50,$20,$A0,$00;Yellow Dragon (Room,X,Y,Movement,State)         

     .byte $04,$50,$20,$A0,$00;Green Dragon (Room,X,Y,Movement,State)         

     .byte $0E,$80,$20        ;Magnet (Room,X,Y)   

     .byte $11,$20,$20        ;Sword (Room,X,Y)   

     .byte $14,$30,$20        ;Chalise (Room,X,Y)   

     .byte $0B,$40,$40        ;Bridge (Room,X,Y)   

     .byte $09,$20,$40        ;Yellow Key (Room,X,Y)   

     .byte $06,$20,$40        ;White Key (Room,X,Y)   

     .byte $19,$20,$40        ;Black Key (Room,X,Y)   


It would be easy for me to allow the modification of the Room # that an object is located in, however I don't fully understand how to translate the X,Y hex numbers into an actual location on the screen. Nukey Shay, could I trouble you for a little assistance on understanding how X,Y object placement works? :)

Link to comment
Share on other sites

Sure...the X co-ordinate runs from $04 (the left side of the screen) to $9a (decimal 154, the right side). And the Y co-ordinate runs from $0d (decimal 13, the bottom of the screen) to $69 (decimal 105, the top). Just use straight decimal-to-hex. These numbers are slightly inward...because if you place objects right at the edges of the screen, you'll run into problems trying to get them.

Link to comment
Share on other sites

I've finally finished the last and final feature that I'm going to be adding to the application. You now have the ability to change the Room location and X/Y Coordinates of all of the objects in Games 2 & 3, and most of the objects in Game 1. I've also updated the Help screen to be a little more informative. I also fixed the one remaining bug that I was aware of, that you couldn't run dasm from a file path that included spaces.


I ran into another limitation of VB, as I'm getting "Procedure too large" errors on the source creation routine when I include the variables to change the placement of the dragons for Game 1. I removed them, and everything's fine. So, unless I re-write the entire routine that creates the source, I've reached my limit on what I can add. I didn't figure that was a big deal, as I don't think many people play on Game 1 anyway.


From here on out, the only changes I'll be making will be fixing any bugs that may be found, updates to the help screen, and possibly a few user interface tweaks to make the application easier to use. So, I'm making v0.29 an official "beta" release. After I play around with it for a week or two, and based on feedback (or lack thereof) during that time, I'll plan on releasing the finished "Version 1.0" by the end of this month.


Full setup package download:




Link to comment
Share on other sites

Atarius; would it be cool to link this thread on my hacks page? My hacks page is full of all the different hacking tools that I have seen here so far from AAs hack section. The page includes downloads to present. Since this one is an ongoing project, I though I could atleast link to the thread until its finished. Although I am a MAC user, I have to applaud you big time. Without your CYOA and Nukeys determination, there wouldn't the new adventure plus addictions that some of us suffer from. So cheers and thanks again! :D

Link to comment
Share on other sites

Atari Troll,


Sure, you can link to this thread from your page. You didn't really need my permission, but thanks for asking anyway. :) And yeah, I'm a mac user too (I use both), but I don't have any development tools for the mac. Sorry.


This app is free for everyone, so you and anyone else are free to host it on their personal webpages when it's done.



Link to comment
Share on other sites

I just started playing with this editor and would like to say thank you for this awesome little program! As a newbie to programming (not counting learning basic in the 80's) I was able to figure out all the things I was doing wrong in about an hour after reading all the posts in this thread. I was able to mess around with some scenes and colours (ahhh... Blue Castle and dragon; I shall call him Bluey) but my current map creation skills are nowhere near the other adventure hacks I've seen.


Adventure has always been my favourite Atari 2600 game and it's nice to be able to make up my own maps after all these years. Thanks for your efforts and keep up the great work! :)

Link to comment
Share on other sites

Well, I'm in the process of trying to do some comprehensive bug testing by actually creating a new Adventure hack with this application. I'm going to try and use every screen to make multiple changes, and make sure everything works as designed. And yes, I already found some bugs tonight. :(


:arrow: The Black Castle Entry Maze map was setup incorrectly to use an assymetric playfield. It's been fixed.


:arrow: I added the ability to change the color of the screen below the Blue maze entry, and noticed a problem with the save file routine on the Color edit window in the process. It's been fixed, but you will no longer be able to use your old "colors.dat" save file. To preserve your old map save files, simply save a new set of files in a new directory, and copy over all of your old files EXCEPT for colors.dat.


I'm about 75% complete with my new hack, I'll post it, along with the .dat save files when I'm done.


Thanks for posting the compressed verison again Greg. I'm not trying to create more work for you by releasing these so quickly!


And thanks for the compliment atwwong, glad you like it!


Link to comment
Share on other sites

My hack is finished, and I found a few more bugs. I've been so busy writing the app, I haven't taken the time to actually USE it, which is why these problems have gone overlooked.


The Level Select room was not being saved AT ALL, so it is now being saved as Map23.dat. Because there is now an additional save file, the load routine looks for it and fails if it can't find it. To get around this problem when loading older saved files, simply make an additional copy of Map1.dat, rename it to Map23.dat. It will load in whatever you had on Map1, but you can simply clear the playfield and start over on that screen.


The Bridge Sprite and Dragon Attacking sprite were saving correctly, but were not re-loading the last four and two bytes, respectively. That has been fixed. Your old save files will still work fine with them, but will actually load all of the data now.


Now, to the hack. I changed just about everything just for the sake of changing it, I didn't put much thought into the actual design of the sprites and maps (so please don't make fun of them ;) ), but everything works and is functional. I did this hack as a sample of what the application can do, not necessarily as the ultimate Adventure hack. Most of the room colors have changed, most of the objects have been moved (although maybe not much), and some maps were made invisible that previously weren't. It's still kind of fun to play, since it's so different :).


Next, I'm going to do the same thing all over again. I'll try and change all of the things that I DIDN'T change in this version. I want to make sure that this application is as bug-free as possible.


The .dat files included are designed to work with the latest version I am posting, v0.31.



Link to comment
Share on other sites

I've been playing with version .31 and having fun changing some sprites. This is great but it's getting late...


I've noticed a bug where the thin black vertical lines in the corridor rooms and the left of easter egg screen disappear after you save and load the file a couple of times.


Also, the default red maze in the white castle is different from the original adventure, but I guess that doesn't really matter much since people will probably edit the maze anyways.


Anyways, great job and time for me to hit the sack...

Link to comment
Share on other sites

I've been playing with version .31 and having fun changing some sprites. This is great but it's getting late...


I've noticed a bug where the thin black vertical lines in the corridor rooms and the left of easter egg screen disappear after you save and load the file a couple of times.


Also, the default red maze in the white castle is different from the original adventure, but I guess that doesn't really matter much since people will probably edit the maze anyways.


Anyways, great job and time for me to hit the sack...


Thanks for reporting the problem with the white castle maze and the thin vertical line. I can easily fix both of those problems. The white castle maze and the black castle maze are the two areas that have the least amount of bug testing from me, because you have to actually play the game for a while to get to them. It gets tedious to make a small change and check it when it takes five minutes (or more) to get to the area of the game you changed.


I've been playing around with this quite a bit in the past few days, and haven't found any other problems. Unless people report new bugs to me (well, like you just did), I'm planning on releasing the final version by next week. I'm still working on a few cosmetic changes... I didn't put much thought into the color scheme, for example, so expect to see some changes there. :)


I'm on another business trip this week, so I should have lots of time at my hotel room in the evenings to finally finish this thing up. No kids to interrupt me!


Thanks for your feedback! It's always appreciated. :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...