Jump to content
  • entries
    54
  • comments
    12
  • views
    3,651

Player 2 auto triggering fire button...again!


-^CrossBow^-

365 views

I already touched on this in an earlier blog post not that long actually, but I will summarize again really quickly.

Main issue is that in 7800 mode and games, one or both fire buttons might show as being pressed without a controller plugged in. Plug in a controller and everything behaves as it should but ultimate, the console shouldn't read anything actively from the ports without a controller plugged in.

In my previous blog, I mentioned that an out of spec resistor located at R35 was only reading about 217Ω while the schematics state that this resistor and the on next to it, should be reading 220Ω. Most of the resistors in the 7800 I believe are 5% tolerant meaning that the value of the component should read within +|- 5%. In this case, such a resistor would still be technically in spec if it were reading as low as 209Ω or as high as 231Ω would still be within that 5% tolerance. So a resistor reading 217Ω is well within the tolerance spec of the resistor.

This was likely fine years ago when everything was much newer, but it seems as the equipment begins to age, these values become more and more tight and the tolerances allowed will no longer work.

Because to fix this 7800 over the weekend, required that I again find a replacement resistor that was reading closer to 220Ω to resolve the issue. In this case, the resistor reads 219Ω.

I've attached a picture that shows the location for these resistors. R34 affects player 1 and R35 affects player 2. And again, these resistors only seem to come into play as causing an issue when the console is in 7800 mode. You can actually remove these resistors and the 7800 fire buttons will still work properly on 7800 games. But they will not work in 2600 mode. So the resistors are only needed for 2600 mode but if will actually effect 7800 trigger readings once they get to a certain threshol.

To be fair I don't think these resistors are just suddenly now starting to read off spec. I suspect the issue is actually the TIA starting to show signs of failure internally as swapping out TIAs will also fix this. But for now, with TIA being much more expensive to replace than a simple resistor, I'm going with changing out resistors to be more in spec going forward and I might just start stocking up and replacing out R34 and R35 with 1% types as part of preventive measures.

 78_P1P2_FB_Trigger.jpg.2a6a03c879ceb37436cac2eb8e3307c8.jpg

View the full article

0 Comments


Recommended Comments

There are no comments to display.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...