Jump to content

Dunjonquest Morloc's Tower


Recommended Posts

Does anyone know where I might be able to find a working ATR image of Morloc's Tower?


The one on Atarimania seems to be faulty, it loads up nice enough but as soon as you try to leave the first room, more of the dungeon fails to load properly. Anywhere else I've looked just seems to be a copy of the corupt image on Atarimania. This copy neither seems to work in the emulator or my real Atari 800.


I have been a big fan of Epyx (Automated Simulations) since I very first started using an Atari computer in the early 80's. Jumpan was one of the big motivations for me to work all summer one year as a teenager to get a disk drive. Temple of Apshai was the very first CRPG I ever played (original basic version.) Lately I have been revisiting the Dunjonquest series, but this one game has eluded me.


I also have been trying to rebuild my collection of Epyx games from the '80s. Sadly the way many people are way over charging for these games (way outside my budget anyway,) has made my rebuilding of this collection a slow one. Recently I just purchased Crush, Crumble & Chomp! at a decent price but am still waiting it's arrivial. Here are some of the games that I have managed to get so far;




CC&C will probably be my last purchase for a while due to the Christmas Holidays season coming up. The Jumpan box, even though it says C64 on it, I have disks of both it and the Atari version in there as well as loose Jumpan Jr. carts for both systems.


Anyway if anyone can help me locate a working copy of Morloc's Tower (atr format as I use aspeqt which I don't think supports ATX,) I'd greatly appriciate it. Thanks.

Edited by KBRpilot
  • Like 1
Link to comment
Share on other sites

Does anyone know where I might be able to find a working ATR image of Morloc's Tower? The one on Atarimania seems to be faulty, it loads up nice enough but as soon as you try to leave the first room, more of the dungeon fails to load properly.

I just tried the zipped ATR that I have on my hard drive. This ATR matches perfectly with the one on AtariMania (which is probably where I got it). I see what KBRpilot means that the game doesn't work correctly. I can exit north, and it works okay, but then when I exit that room, I exit the Dungeon (well, Morloc's Tower). The only proper exit from that Room 7 (the room that the player begins in on first starting the game) should be to the south. Exiting west also exits the Tower. Exiting east sort of works, but it doesn't appear to work correctly, as I was attacked by a Dire Wolf from two rooms away (which I don't think is normal, is it?).


Like many early Atari games, the graphics of "Morloc's Tower" are quite primitive (and they're also monochrome). Still, the game is pretty neat, but it plays quite differently than "Temple of Apshai:" games are limited to 20 minutes.

Link to comment
Share on other sites

I tried "Morloc's Tower" (under emulation) on an Apple II using Applewin 1.24 in order to check if the game works as I expect it should work on an Atari 8-Bit. "Morloc's Tower" works just fine on an Apple II. I made a few screenshots to show that exploring the game works correctly on an Apple II.


Here is what "Morloc's Tower" looks like when it first begins:



Here is a screenshot of the game after the player's character opens the west door:



Here is a screenshot after six rooms have been explored:



If you're familair with "Temple of Apshai," that you may notice a difference in how the map is drawn. Only the current room that the player's character occupies In "Temple of Apshai" is drawn on the screen. In "Morloc's Tower," each room that has been explored (thus far, at least) is still shown.



Link to comment
Share on other sites

"Morloc's Tower" for the Atari is written in BASIC. You can see the AtariMania version, here:


A listing of the files on the disk shows these files:

DOS SYS 0037
DUP SYS 0042
LESSMORE001 0035
TOWER 0010

I loaded "LESSMORE.001" (the file loaded by AUTORUN.SYS) into BASIC and then LISTed it to my h: drive using the Altirra emulator. Here is a ATASCII version of the file of that file:




Note that if you open this with a regular text editor (for instance, Notepad under Windows), then the file will have garbage in it). The file can be viewed properly using an ATASCII editor, such as ATASCIIView (for Widows).


Here is a pdf version of the same file for easier viewing (but it's not searchable):




LESSMORE.001 loads the main "Morloc's Tower" program called "LESSXREF." Here is an ATASCII version of "LESSXREF:"




Here is the same file as a pdf for easier viewing:




Hopefully this will allow someone to spot a potential problem with the "Morloc's Tower."

Link to comment
Share on other sites

  • 2 years later...

Does anyone know where I might be able to find a working ATR image of Morloc's Tower?


I still don't know where you can get a working disk image of Dunjonquest: Morloc's Tower, but I did get the original disk for the Atari 8-bt yesterday:




I don't even have a disk drive, so I can't test if it works, but I'm working on trying to get someone to archive this disk for me. I'll keep you posted.



  • Like 4
Link to comment
Share on other sites

I still don't know where you can get a working disk image of Dunjonquest: Morloc's Tower, but I did get the original disk for the Atari 8-bt yesterday:


attachicon.gifDunjonquest - Morloc's Tower.jpg


I don't even have a disk drive, so I can't test if it works, but I'm working on trying to get someone to archive this disk for me. I'll keep you posted.


I would have made an image of my Morloc's Tower before I sold it, but it was a sealed copy...


post-6369-0-32006200-1510367208_thumb.jpg post-6369-0-36944200-1510367214_thumb.jpg


Link to comment
Share on other sites

Yes, and it will remain sealed as part of my Epyx collection. If you have one not seen below and it is for sale, contact me (Early Epyx titles only, system doesn't matter)


14168607352_44123ab8ea.jpgimage by Mark Gladson, on Flickr


14167991661_fc9ee7b2f9.jpgimage by Mark Gladson, on Flickr


Very nice collection. I have a number of sealed copies of your open ones, Jumpman, Temple of Apshai, Gateway, Monster Maze, Alien Garden, Plattermania, as well as some variation packaging of titles you have and couple of oddball EPYX titles you're missing, like Fun with Art. I even have some commercially produced bootleg Epyx titles complete with misspellings on the box ("Gateway to Apsh").


I'm an SSI/Avalon Hill/Infocom/Origin/Epyx collector, with room for RPG's and strategy titles from any publisher.

Edited by GlowingGhoul
  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

Kevin Savetz dumped my Morloc's Tower disk. It has errors on it (which he presumes is copy protection). He uploaded a kryoflux dump of the disk here:


He is hoping that someone can get the game to work. So... progress is being made. If my disk is bad, then maybe someone else can get a good disk dumped of this game.


  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

I wouldn't assume the disk is bad, or should I say so bad it can't be read. It's happened a few times with a disk cleaning or different drive or both a second or third try and it works. KryoFlux doesn't always get it on the first try, sometimes scp gets it and vice versa

Link to comment
Share on other sites

  • 2 weeks later...

I remember having a Fantasy Role Playing Game back in the day. Might had been written in Basic. That did maps in graphics 0, redefined font. Had the Dungeons & Dragons attributes (Charisma, Strength, Dexterity, etc) and when you died states "Though Art Dead." Been long time ago, and I think the game had an error in it. Not sure if I had the finished version. But as you know I like this sort of game.

Link to comment
Share on other sites

  • 2 years later...

Hello, AtariAge members.  Apologies for the necro, but I hope you'll find this worth the breach of etiquette.  I'd like to revive this thread with the attached disk image, a potentially-more-functional copy of Morloc's Tower for the Atari 8bit series.  By offering this, I hope to end the searches of other Dunjonquest fans and possibly resolve the issues described in this thread with the existing dump available on Atarimania.


After speaking with Bertrand of Atarimania, I've provided them with a copy of the disk image for testing.  During my conversation with Balleyalley, they suggested posting the image here in order to get a greater audience for testing the image.  This sounded like a great idea.


To this end, please give the attached image a try and let me know how it goes.  If you're looking to use real hardware, I found that the usually-trusty Disk Wizard II fails when writing the image to a real disk.  I ended up using an older version of Copy2000 to write a copy to disk (gotta save wear and tear on the original).  Streaming the ATR through a SIO2PC cable appears to work just fine.


A few points to note when playing this, as it's a bit different than most Dunjonquest titles (even from Datestones of Ryn).  Please check out the below spoilers if you do not want to head in blind.



- This game basically requires the manual, so here's a link for a copy. 


- As with most of the Dunjonquest games, BASIC is required.  Make sure your emulator is set accordingly, or you've got that taken care of on the real hardware side before loading the game.


- You have 45 game minutes to complete your objective, which is roughly real-time.


- Room layouts are mostly static, room contents are randomized.


- Opening a door automatically advances your character through the doorway.  I believe this is the only game in the series to do this.


- Firing an arrow that appears to "pass through" an enemy still counts as a hit.


- Some creatures cannot be struck with melee combat, only arrows.


- Several enemies appear to be pacifists.  Living Armor and Hellhounds are described in the manual as bloodthirsty, but they only wander around without attacking.


- The usage of the "U" key seems unique to this title, allowing use of a treasure to solve a puzzle.


- If you can survive the salamander room by grabbing the treasure and escaping, you're a better player than me.  That room is lethal.  :)




Cheers to my fellow adventurers and good luck in the Tower!



Dunjonquest - Morloc's Tower.atr


  • Like 5
  • Thanks 5
Link to comment
Share on other sites

The essential difference between the dumps is that @zapsterx's dump has only 1 buffer defined in its DOS whereas Atarimania's dump uses the default value of 3.

If you change bytes 26 and 27 of Atarimania's dump from $03 $03 to $01 $01 then it works as well.


Zapsterx' dump is based on DOS 2.0 and therefore seems more original than Atarimania's dump which is based on DOS 2.5 which was not available when Morloc's Tower was released in 1980.


"Just because" I attached a fixed Atarimania dump.

Morloc's Tower Atarimania fixed.atr

Edited by DjayBee
  • Like 3
Link to comment
Share on other sites

Good find, @DjayBee!  I am looking forward to trying the fixed image.  I wonder how the first Atarimania dump was created and if that may explain the difference between the two.  I do not know much about image editing or Atari programming, so anything further would be speculation on my part.


In any event, when it rains, it pours.  Asphai fans have gone from zero good images to possibly two! :)  Thanks for your response.

  • Like 2
Link to comment
Share on other sites

  • 1 month later...
On 10/25/2020 at 2:10 PM, zapsterx said:

I've provided [Atarimani] with a copy of the disk image for testing.  During my conversation with Balleyalley, they suggested posting the image here in order to get a greater audience for testing the image.  This sounded like a great idea.


Cheers to my fellow adventurers and good luck in the Tower!


I finally tried playing the newly dumped disk image of "Morloc's Tower" under emulation and on real hardware.  I first tried it on real hardware last night and I thought I had issues with the disk image.  I went into the west room from Room 7 (the starting room), but then I could not leave that room.  I tried all sorts of methods to leave, such as trying to find secret doors, but to no avail: I was stuck.  I thought I would give this game another try today.


This morning, I loaded the game using my Windows 7 PC with Altirra 2.80.  The game loaded fine, but I was having the same issues moving about the rooms under emulation as I had when I played it on real Atari hardware last night.  However, I wasn't going to give up so easily today.  I briefly skimmed the "Morloc's Tower" manual to see if I missed anything, but it seemed like I was playing the game properly.


After some additional frustration, I happened upon the "solution."  This really isn't a solution at all, for it just seems that this not-often-played Dunjonquest game has character movements that are quirky and unlike others I remember playing in any of the series before now.  In the other games, if you want to move through a door, then you must open it first.  That was what I tried to do with the northern door.  Yet, I kept being greeted by the phrase, "YOU CAN'T" in response to my OPEN command.  From what I can tell, it is just a doorway with no door.  I tried taking one step at a time to pass through the doorway, but that did not work.  Eventually, if I made three steps at a time, then I could pass through the open doorway.


The East and West doors from Room 7 are actually doors and they need to be opened.  Sometimes when I was standing in front of the door and I opened it, then I automatically entered the room.  Other times, when opened a door, I still had to walk through the doorway by making at least three steps at a time.  Maybe this has to do with my character's exact position when I open a door.


The game seemed okay when played under emulation, but would "Morloc's Tower" work when loaded from an SIO2SD on my 130XE?  I played the game again, and it works fine, in the few minutes that I played it.

A few years ago I discovered that I could speed-up the BASIC version of the game of "Temple of Apshai" by playing it using the "BASIC XL" cartridge.  Would this also work with "Morloc's Tower?"  I plugged in my "BASIC XL" cartridge into my 130XE and loaded the game.  It did indeed run faster.  It doesn't make the game run smoother, as there is no proper animated movement (your character and the monsters moves in "blocky" steps).  However, when the rooms are drawn on the screen, they are drawn much more quickly.


I'm going to play the game some more over the next couple of days.  Since I've waited so many years to play this game on the Atari, I figured I may as well use it as a subject of one of my Atari videos.  So far, I have four videos my Atari playlist on YouTube, which is here:



Has anyone else tried playing "Morloc's Tower" yet?  What are your thoughts on it?



  • Like 1
Link to comment
Share on other sites

Glad you were able to give this a go.  Your description of the wonky doors and room entry behavior falls in line with my experience from my original.  The “jumping” required to pass through doorways is especially odd since no other Apshai game appears to behave this way.  For my part, I attempted to explain this via Spoiler #5 in my original post, but I perhaps I should have went into more detail. 


Since my primary machines are a 1200XL and 800XL, I decided to attempt loading the game alongside the “A” and “B” versions of the the Atari Translator disk.  I did not notice any differences to the gameplay via Translator, but I have yet to explore every room.


The use of an alternate Basic was clever. I will definitely give that a try on my end. I wonder if any speed boosts here would affect Morloc’s Tower and Datestones of Ryn to their detriment?  Both of the “microquests” are timed a bit too agressively for my tastes as it is.  I am looking forward to your further delves into this game.


Now that I’ve played a bit more, I still have the feeling all is not right.  The projectile graphics for the Salamander room are a bit dodgy, and I still can’t get over the hellhounds mindlessly prancing around.  I called it out in the original post, but I really expected combat in this game to be on par with previous games in the series.  Many creatures appear to be unfazed by melee combat, period.  Perhaps some other retro sleuths could examine the game’s code and offer fixes to this ancient title?


That’s all for now.  Good luck and I hope to hear more soon!

Link to comment
Share on other sites

On 12/11/2020 at 10:25 AM, zapsterx said:

Glad you were able to give this a go. 


After playing the game for a few of hours of a couple of days ago, I have created a very early draft version of my hints, tips and maps for the Atari 8-bit version of Automated Simulations' "Dunjonquest: Morloc's Tower."


Here's a picture of the cover:




In this handwritten document, the maps and notes are not complete... but it's a start.  Here is a pdf of the six-page document:




Take a look and give the game a try.  It's very different from the Apshai games.  It feels, I don't know, early.  I guess its release in 1980 wasn't too long after the Atari home computers hit the market in, I think, November of 1979.  That's probably why the game looks so simple and is monochrome.  Plus, of course, it was written in Atari BASIC, but so were the original "Temple of Apshai" games.


I'm going to try to play this game some more this week and finish the maps and get rid of that baddie, Morloc.  After that, I'll do my best to make a video of the game.


I'd like to hear feedback from anyone else who has given the game a whirl so far since the working disk image has been dumped.



  • Like 2
  • Thanks 3
Link to comment
Share on other sites

I am making notes about Dunjonquest: Morloc's Tower for my personal game-play use.  I thought that I would be able to find a text version of the manual.  I found a few versions of them on the Internet, but they seem to have been created by auto-OCR software; they are full of errors.  I tried to proofread them but then I gave up and decided to OCR and proofread part of the manual myself starting with the three-page story on pages 12-14.  Here is the complete story.


If you like the Temple of Apshai games, even if you haven't played "Morloc's Tower," then I think you'll like this short story.  Like the previous stories in the Dunjonquest series, this one has some funny bits and is littered with hints.  Unlike the Apshai series, where each numbered room has it's own description, the only description the player is given of the contents of the thirty rooms of the tower are framed within the walls of this story, the brief monster descriptions and the short descriptions of the twelve treasures.


Enjoy the story!






Dunjonquest: Morloc's Tower
Automated Simulation


The Adventures of Brian Hammerhand


   It began as an orange shimmering in the air, like a mirage glimpsed in the desert. A moment later the fireball was a miniature sun, painful to look upon and hot as the fires of hell.
   The adventurer, Brian, called Hammerhand, recoiled involuntarily, his hand rising to his eyes to shield them from the searing dazzle. "Geb's Beard!" quoth he.
   An instant later there was naught left of what had been a sandal-maker's shop but a persistent spot in Brian's eye and a blackened circle on the ground. The sun-baked brick of the shop next door, a weaver's, could not burn, but through one crumbled wall he could see an old man with singed beard mechanically beating out a small fire with a faded blanket.
   There was no general outcry, and, indeed, the few on the streets passed by with no more than a furtive glance. Puzzled, Brian stood athwart the path of the third passer-by. "Does this happen often?" he demanded.
   Eying the bulk of the adventurer, the man halted. "Twice or thrice a day, since the last full moon."
   "What's the cause?"
   "Morloc the Mad," offered the fellow promptly, nodding in the direction of a tall, solitary structure on a hill overlooking the walls of Hagedorn. "A wizard," he added, as if this explained matters.
   "A wizard warring on weavers and sandal-makers?" repeated Brian dubiously. While magi were a strange and unpredictable lot, in Brian's experience they were loathe to leave their arcane researches and rarely bothered (or could be bothered with) mere townsfolk.
   "'Tis hardly a thing to be wondered at, when a man keeps the company of demons and spirits best left alone."
   "Demons?" said Brian, glancing about uneasily.
   "Well, unnatural beasts and creatures inhuman, at the least," the fellow conceded. "Even a salamander, they say."
   "A salamander?" said Brian, his bafflement showing.
   "Have you not more wit than an echo?" cried the oldster, with the reckless rudeness of age. "Not the natural sort, of course-- a creature of fire in the form of a lizard. Treacherous as snakes, they are, and servants of none, whatever's said, though," he added reflectively, "they do say it was one of his own fireballs, out of control, that burned Morloc, body and soul, beyond healing. He's quite mad now, certes. In a fortnight there won't be a building left in Hagedorn save his tower."
   "Methinks someone should acquaint this mad wizard with the benefits of cold steel."
   The townsman nodded agreeably. "No doubt the elders would be pleased to have you do so."
   "Why else are you come to Hagedorn?"
   As Brian sought an answer to the question he had asked of himself since first he passed through the ruined gates of the pockmarked town, the oldster edged around him and continued on his way. "Wait!" called Brian belatedly. "Where are these... elders?"
   "Oh, you'll find them easily enough, if they don't find you. Look for the tallest building in town-- if it's still standing when you get there."
   From his welcome by the town elders, Brian might well have been a visiting prince. The dust of the road was wiped from his worn boots and shaken from his cloak, and he was served-- by what must surely have been the comeliest wench in Hagedorn-- from a ewer of truly excellent wine and a platter heaped with meats, cheese, grapes, and figs. So great was their haste, however, that Brian must swallow a repetition of the townsman's tale with his first mouthful.
   Around a leg of turkey, he mumbled in response, "Yon tower's tall but of no great width. If there's but a single staircase, it should be easy enough to hunt him down within."
   "Not so easy as you think," said the chief of the elders, one Agelar, whose daughter Imelda was keeping Brian's flagon filled. "Though stairs there be, Morloc has little need of them. He appears and disappears at will and, when threatened, can wish himself out of reach or elsewhere in the tower."
   "That will certainly make it more difficult," Brian commented blandly.
   "Nor is that the extent of the difficulties," continued Agelar. "Morloc wears a wondrous cloak which, when enfolded about him, conceals him from sight of all but the keenest eye. He commands the fire that burns the soul, and, although all of his human servants have fled, the tower is guarded by clever traps, ravenous beasts, and magical servitors, some of which cannot, we fear, be harmed by ordinary weapons."
   Brian rose hastily. "My thanks for the meal, but I have recalled an urgent appointment elsewhere."
   "But if you abandon us, Hagedorn is surely doomed."
   "A great pity, but if I do not, I am surely doomed." He ignored the look of reproach from the fair Imelda.
   "We will pay you 5000 gold pieces."
   "Not for--. Gold?" He resumed his seat abruptly. "As I was saying, it would be the gods' own shame if everything in Hagedorn were destroyed," he said, none-too-covertly eying the fairest item therein, who seemed well pleased with his change of heart.
   Agelar sprang to his feet, clapping his hands together. "We will give you what aid we can, but you must prepare to leave at once."
   "But I have scarcely begun eating," complained the reluctant hero.
   "That cannot be helped. Morloc has sworn to level the city by the rise of the new moon."
   "That's tonight!"
   "Yes, and none of us shall see another sunrise if you fail."
   Nonetheless, Brian used the few moments before the servants reappeared to good advantage. If he, too, were destined never to see another sunrise, he would meet his fate with a full belly.
   The first item brought in was a full suit of black adamantine plate, inlaid with what seemed to be brass. It looked heavy and was. Hefting the thick breastplate, Brian shook his head. "I'd as lief carry a horse on my back."
   Agelar's smile was grim. "Your horse might prefer it, also, but the guardians of the tower would chew through that mail you wear like so many rags. That is not brass but enchanted aurichalcum, which will give you some protection, however slight, against even magical fire."
   "Much good may it do me if I'm too tired from lugging it around to swing a sword," grumbled Brian, unmollified.
   "It will be light enough if you do not try to carry off everything that happens to catch your eye," replied Agelar with some asperity.
   Reluctantly, Brian shed his accustomed armor and allowed himself to be helped into the heavier plate. "What of those?" he asked, of a set of stoppered flasks. "Healing potions."
   Brian's initial, pleased reaction did not last past a moment's reflection. To have need of so many healing potions, it were a dangerous venture indeed. He glanced again at the fair Imelda and looked back at Agelar glumly. "Nor this armor nor these elixirs will slay you a wizard."
   "Despite his powers, Morloc is as mortal as we here. If he stays to fight you, he can be slain like any man, though his cloak makes it hard to strike a true blow. Against those of his servants who may be proof against your other weapons, however, we can only offer this potent arrow. Do you use it well."
   "I'd rather a sword," replied Brian ungratefully. "Mine has served me long, but it's no more than ordinary steel."
   "Alas, we had such a weapon, embued with an enchantment to alert its bearer when Morloc was near, but it was taken from us to the tower. Belike you may find it there."
   "And if not?"
   "Then you must look for aid elsewhere. In prior days, those who sought to slay the wizard brought rings and charms to aid and protect them. Some may remain, and there are known to be devices of power within Morloc's tower. Of these both, some may be worthless or beyond your use; others, certes, may harm the unwary, but in unforeseen ways, mayhap, many will help, if you can but find them. One such, of immense power but form unknown to us, was fashioned of old by a rival-- not to kill but to trap and confine Morloc forever. This would be as big a boon as aught we could give you."
   "The wizard would be mad, indeed, to keep such things as must be a threat to him. Would he not rather destroy them all?"
   "It is not so easy to destroy ensorcelled objects as you suppose," counseled Agelar. "Mayhap he has use for some or hopes to turn them to his purposes. Too, it is said that against the ancient artifact Morloc made a counterdevice, which it amuses him to keep about the tower in innocent-seeming form, there to tempt his foes to their later dismay. Nor would it require more than the simplest of protective spells to alert the tower's guardian spirits if the sword were disturbed. And what better place to keep one's bane than under certain guard and watchful eye?"
   So it was that Brian Hammerhand stood before the tower of Morloc the Mad, the weight of the strange armor heavy upon him, the light of the afternoon sun hot upon his back. Tall and square was the tower, its walls blank and grimly forbidding. Grim, too, was the pile of bones near the base. Once human, perhaps, they were crushed and broken now, bare and dry.
   His gaze shifted back to the massive double doors which opened onto the central courtyard. Through those doors and to the right was a broad staircase ascending all the way to the topmost floor, six stories up. Elsewhere on the ground floor he had been told, lay what remained of stables, kennels, and stores. Above was the great hall, and above that the kitchens and such. The fourth floor had been servants' quarters-- and might still be, though none human remained. The fifth floor held the wizard's personal chambers, though few had been past the anteroom there, while 'twas said the top level was devoted to arcane researches and strange experiments.
   He shrugged. Morloc might be anywhere within, but he would not be found by staring at the tower from without. The meeting was set, and tingle in his veins bespoke the appointed hour.
   'Ware, wizard, he thought. Heaving open the massy doors, he drew sword and strode within the dark and silent courtyard.

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...