Jump to content

Nomad it's dead, help please


Recommended Posts

I've got power from the power port to and through the switch, but neither of the regulator outer pins have power. I'm not sure where to go from here.




I assume you're talking about the Voltage Regulator? I've never worked on a nomad, but if it's like the genesis, it will have 3 prongs on the regulator. One is ground, one is input voltage (10v approx.) and one is output voltage (5v approx.). If you're not getting 5, but get 10 = replace the regulator. If you're not getting 10 or 5, check the trace from there to power switch for continuity.


I assume you have a no response issue with the unit?

Link to comment
Share on other sites

  • 2 weeks later...

Correct, it doesn't do anything. And yes I'm talking about the voltage regulator. The middle pin is ground and it ohms out just fine. The left leg should have 13v and the right should have 5v, but neither leg had any power, yet power is getting through the dc port and through the power switch.


Interesting. I wish I could help further, but without the unit in my hand, it's hard to say. I've never actually worked on one. Good luck though, maybe others will chime in.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...