Jump to content

The FinalGROM 99


Recommended Posts

thank you very much, we assembled these FGs, the situation at the moment is this, AVR programmed with Atmel ICE and verified with a working FG. I don't understand if the problem could be with CPLD or with ATMEL. When I power the FG the LED flashes approximately 1 time per second, if I insert the SD with the CPLD programming file and do the reset, the LED flashes six times quickly, I have tried various SDs..

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

hi, everyone, I have two fg99s with this problem, when I insert the SD card with the update.pld file the LED stays on, and never goes off. Has this happened to anyone? I tried replacing both the 328p and the Xilinix...

  • Sad 1
Link to comment
Share on other sites

Based on your description, I probably had an error similar to yours at some point when I built my batches of FinalGROM.  If the LED doesn't blink, it's not a "regular" error, like file not found.  The error codes returned by the JTAG library are also translated to LED signals.


I assume the working and non-working boards have the same AVR software?  If so, I would check if you have bad solder somewhere so that some signals are not going through.  Also, did you set the AVR fuses correctly?  How long did you wait for completion?

Link to comment
Share on other sites

On 18/3/2024 at 18:37, ralphb said:

In base alla tua descrizione, probabilmente ho avuto un errore simile al tuo ad un certo punto durante la creazione dei miei batch di FinalGROM. Se il LED non lampeggia, non si tratta di un errore "normale", come file non trovato. Anche i codici di errore restituiti dalla libreria JTAG vengono tradotti in segnali LED.


Presumo che le schede funzionanti e non funzionanti abbiano lo stesso software AVR? Se è così, controllerei se hai una saldatura difettosa da qualche parte in modo che alcuni segnali non vengano trasmessi. Inoltre, hai impostato correttamente i fusibili dell'AVR? Quanto tempo hai aspettato per il completamento?

the FW is the same for all and the lock bits are the same (checked directly with atmel-ice), I attach both the TDO and the TCK seem blocked by something. I assume that the update file is read well since the LED lights up steadily, are the CD0-CD7 bits affected when programming the cpld?  Sicuramente è una stupidaggine !



Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...