Jump to content
IGNORED

Totally dead AtariArtist cart


Recommended Posts

I picked up a Touch Tablet full package for pretty cheap on Ebay, and it came with everything including the AtariArtist cart. Unfortunately I can't seem to get any life out of it whatsoever. Cleaned the contacts with DeoxIT D5, reflowed every solder connection, checked continuity on all traces, and tried in a couple different computers... nothing. Computer basically behaves like there is no cart installed. I can boot to DOS and try 'run cartridge' and get "No cartridge" back.

 

First time I've ever seen a cart failure like this, anyone else experienced this? I suppose it could have been used in an Atari with a failed power supply and the PROMs could be toast from over-volting, but I can't come up with many other likely scenarios.

 

I was able to find AtariArtist in ATR form and test out the tablet, but I'd still like to have a working cart for my collection. If I got ambitious I suppose I could just make one with EPROMs, but I'm not sure I'm that motivated.

 

Link to comment
Share on other sites

I picked up a Touch Tablet full package for pretty cheap on Ebay, and it came with everything including the AtariArtist cart. Unfortunately I can't seem to get any life out of it whatsoever. Cleaned the contacts with DeoxIT D5, reflowed every solder connection, checked continuity on all traces, and tried in a couple different computers... nothing. Computer basically behaves like there is no cart installed. I can boot to DOS and try 'run cartridge' and get "No cartridge" back.

 

First time I've ever seen a cart failure like this, anyone else experienced this? I suppose it could have been used in an Atari with a failed power supply and the PROMs could be toast from over-volting, but I can't come up with many other likely scenarios.

 

I was able to find AtariArtist in ATR form and test out the tablet, but I'd still like to have a working cart for my collection. If I got ambitious I suppose I could just make one with EPROMs, but I'm not sure I'm that motivated.

 

 

That totally sucks! :( I don't have any dead A8 carts but I have one dead 2600 carts (out of nearly 200). ROMs just appear to have failed - microscopic corrosion or imperfection in the semiconductor crystals that grew over the years, I suppose.

 

 

Send me your address, I have a spare

 

 

And that's why this community is great. :)

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...