Jump to content
IGNORED

Colecovision controller woes


rednakes1
 Share

Recommended Posts

Yesterday I tried out a Colecovision controller that I bought at the flea market for very cheap. Unfortunately, I got what I paid for, as it has been giving me a lot of grief.


The original problem was that the Up and Right directions did not register at all. With my multimeter I was able to narrow this down to damaged traces on the PCB. So I fixed this problem by connecting a wire to the parts that could not be reached by the Up and Right direction contacts, as can be seen in the attached photo. Afterwards everything worked great, the controls were smooth and perfect!


However, after a few minutes I noticed that the controls intermittently would stop working for a second or two, and then come back again, and then stop working again. This went on for a few minutes and got worse and worse (longer stoppages), until none of the controls except for the Right fire button worked at all. I noticed all of the keys on the keypad were working as well.


Does anyone know what could have caused this?? Judging by the intermittent behaviour, it seems like a cold solder joint somewhere but I don't know how to narrow it down. Do all the controller directions and left fire button eventually share a common point? I can't figure out why only the right fire button is working (along with the keypad). Could this be a diode issue?


I also tried my other Colecovision controllers on the same controller port and they work fine.

post-47549-0-49524200-1496643352_thumb.jpg

Edited by rednakes1
Link to comment
Share on other sites

 

So I saw this page with a description of the pinouts:

 

http://old.pinouts.ru/Game/colecovision_controller_pinout.shtml

 

"when pin 5 is connected to power, the keypad and right trigger are activated.

 

When pin 8 is powered, the joystick and left trigger are activated."

 

 

Ah, so that exactly fits my issue. My pin 8 is not getting power. So I'll have to figure out how to fix that.

Link to comment
Share on other sites

Okay, figured it out! Pin 8 on the controller port (which controls the joystick and left fire button) goes to the grey connector at the bottom of the PCB. With my multimeter I noticed there was no connectivity between the grey connector and the track that leads to a solder point near the middle of the controller, which was likely due to a broken trace again. So I soldered another wire...and now it works!

 

Here's a photo attached. Pardon my shoddy solder job, but it works now and I'm happy ;)

post-47549-0-03319600-1496698274_thumb.jpg

Edited by rednakes1
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...