Jump to content
IGNORED

Need help with 48K 400 RAM failure, but its not the RAM?


ACML
 Share

Recommended Posts

I have an Atari 400 with an INTEC 48K board. It is failing RAM test on CPS Super SALT. When I run the RAM test I get;

 

7 6 5 4 3 2 1 0

E000 00 00 00 00 00 00 00 00

C000 00 00 00 00 00 00 00 00

A000 00 00 00 00 00 00 00 00

8000 00 00 00 00 00 00 00 00

6000 FF FF FF FF FF FF FF 00

4000 00 00 00 00 00 00 00 00

2000 00 00 00 00 00 00 00 00

0000 00 00 00 00 00 00 00 00

 

1) I have another INTEC 48K board, swapped it out and same error, so its not the INTEC board.

 

2) I have another CPU card, swapped it out and same error, so its not the CPU board.

 

What could be causing this type of behavior? Obviously its on the motherboard. PIA and POKEY? Don't know why. Any ideas?

 

Thanks!

Edited by ACML
Link to comment
Share on other sites

If you dig out the ClausB thread on Atari 800 memory selection it describes the nature of Ram selection. http://atariage.com/forums/topic/177885-atari-800-ram-selection/

There's a select line for each 8K block and passthru function where each memory card in the first 2 slots should pick off the ones it's providing then pass the unused ones onto the next slot (vague description).

 

So, for your problem it does seem that the block corresponding to $6000-$7FFF isn't being selected properly (connection S3 ? ). My guess is a problem with the selection logic or break in a select line.

 

Also, isn't it necessary to modify the machine for the larger Ram module sizes?

Link to comment
Share on other sites

Additional - I guess to ensure it's not false error reporting, do a manual check in Basic:

 

? FRE(0)

without a Dos present, should return a figure of 37902

 

POKE 106,128 : GR. 8 : C. 1: PL. 0,0 : DR. 319,191

should open graphics screen and do a diagonal line top right to bottom left. But if that free memory figure wasn't right it'll likely fail.

Link to comment
Share on other sites

Even some 16K programs fail, so its a real failure. I do get the 37902 in BASIC. Could it be one of the smaller DIP chips on the main board between the cartridge slot and the RAM board? Don't know what they do. There are four connections on the back side of the board for the 48K RAM board upgrade. Maybe one is not making good connection. Could that cause this. Am I wrong in assume the RAM chips are fine since each chip is one bit of a byte so all location should fail if one chip is bad. 6000-7FFF is 8K, but only the 7-1 bits are FF and the "0" bit is good. Is that saying some of that 8K block pass? So the 8K block above the first 16K (block 3) is the problem. Is there an address bit that could be broken causing that 8K block to be bad? What chips on the main board would have an effect on the 8K block selection?

Link to comment
Share on other sites

I have a theory on what might be happening. It could be an address line issue that makes memory locations between 16K and 24K fail. What address lines could do this?

 

The theory:

A0 - 2

A1 - 4

A2 - 8

A3- 16

A4 - 32

A5 - 64

A6 - 128

A7 - 256

A8 - 512

A9 - 1K

A10 - 2K

A11 - 4K

A12 - 8K

A13 - 16K

A14 - 32K

A15 - 64K

 

All is good up to A13 being high (1) and A14 is low (0). That gets you to 5FFF or the first 16K of RAM.

At 6000, this is first time A14 is high. For the next 8K (16K to 24K) A13 is low and A14 is high. That's 6000 to 7FFF, coincidentally the bad addresses.

At 8000, bit A14 goes low again and for the next 24K (24K to 48K), A14 will remain low.

The next time A13 is low and A14 is high won't be until above 48K and the RAM test stops at 48K.

 

The common thread for the failure is A13 being low and A14 being high and that only happens between 16K-24K or 6000 to 7FFF. I would repeat again at 48K-56K, but the memory test stops at 48K.

 

So could A13 and A14 being shorted together explain this. Too late to dabble with the multi-meter tonight.

Link to comment
Share on other sites

There's not a direct translation with the relevant address lines.

 

ie - the select lines mentioned earlier select 8K blocks rather than A15 to A13. So from the memory module's point of view, the only things that matter would be A0-A12 and whatever select lines it requires for however many 8K blocks it contains.

 

How'd that graphics one I posted earlier go? That displays a chunk of nearly 8K of Ram which is sometimes a good visual aid to any problems going on.

Edited by Rybags
Link to comment
Share on other sites

  • 1 month later...

My Intec 48K board has 4264 DRAMs. I found out that 4164s are not compatible. Would a 8264 work?

Going by this pictures in this post the F logo(Fairchild?) MB8264-20 are compatible with the Intec 48k board

 

What is the complete part number and manufacturer, the same parts can have different #s when manufactured by different companies, or the same # for different parts.

MT4264 is Microns part# for 64k x 1 bit DRAM which Atari used in the 130XE, AFAIK they are 4164 compatible.

Link to comment
Share on other sites

The 74LS42 on the motherboard generates S3 and the other select lines. Maybe replace that, or at least reseat it (and the other chips). Did you try swapping the CPU card with one from another 400 or 800?

Yes, I tried a different CPU card, but no change. I even used a different mobo with new wires on back and still no go. I verified the new mobo and CPU card with another identical Intec board and it worked fine on both mobos. Aside from the DRAMs, all the other chips are soldered on (i.e. no socket).

Edited by ACML
Link to comment
Share on other sites

In your first post you said the other Intec card failed in the same way. Now you say it works in both 400s?

Correction: I have two 48K Intec boards. The good one works on both main boards. The bad one fails on both main boards, so one Intec board is bad. Probably a RAM chip.

Can I swap a 8264 for a 4264?

Link to comment
Share on other sites

  • 2 months later...

Have you tried taking the ram off the bad board and putting them into the good board, to validate its a ram chip issue?

kheller2,

 

I finally got time to do what you said and swap RAM from one board to another. Yes, its was a bad RAM chip. Here's the funny part; when I identified the bad chip, I put it on the other board and it now works with that seven, just not the seven chips it came with. So i just swapped one chip and both boards now work. Go figure? I did learn that 4164s will not work on an Intec board.

  • Like 1
Link to comment
Share on other sites

You probably cleaned the oxidation off the chips legs or socket wipes when moving them about or you moved a bad solder connection just enough to make it works again...

Maybe, but it was very repeatable with that one chip. I even re-swapped it to verify it was still an issue and it was in a different socket. I think it could be a timing issue that that one chip didn't play well with the others.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...