Jump to content
IGNORED

Vecadapt malfunction?


genfuyung
 Share

Recommended Posts

Just turned my vectrex on for the first time in a while and when my Vecadapt is plugged in, the up direction is constantly being pressed. I tried flicking the switches on the vecadapt, starting the machine with the vecadapt unplugged and then plugging it in once the power was on, tried plugging the genesis controller into the vecadapt before and after powering on, all with the same result. Even with just the vecadapt plugged in and no controller in the vecadapt its still holding the up direction. Anyone have any idea how to fix this? Pretty bummed out.

Link to comment
Share on other sites

I am looking at a Vectrex for someone and their issue was that when they plugged an AtariVox into the controller port it fried something. When I looked at the Vectrex I found that some of the controller port solder points had been bridged by solder. I guess either the solder bridges were always there but the unit functioned fine until the AtariVox was plugged in OR the solder bridging happened during a cap refresh or noise elimination fix. I'd be interested to know if your controller port has solder bridges as well that cause weirdness when something other than a controller is plugged in. Maybe we are discovering a factory flaw. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...