Jump to content

Power Mac G5 1.6 GHZ pickup, problem.


Recommended Posts

Hey guys. I was at my local Habitat for Humanity today doing a bit of thrifting to kill time before work and stumbled onto what I consider to be quite the find, at least for my area. There was a Power Mac G5 1.6 GHZ tower sitting there with no price looking a little worse for wear but otherwise in pretty good condition. The resident tech expert guy and I had a bit of a conversation about the unit and he agreed to test it out and value it so that I could decide if it was something I wanted to grab. On power up, the fan would spin and the single white LED on the front would flash once every five seconds. Being that there wasn't a chime sound, I knew immediately the system wasn't POSTing successfully and explained it to the guy, who thought for a moment and said that he really didn't want to deal with it and offered it to me for $5.


Yes, please.


A bit of research has led me to suspect the ram as being the culprit. I tried removing and reseating both 128MB sticks, trying them in the various slots, but no change was observed so I ordered a couple replacement sticks to see if they can make it work. I have also read some amount of anecdotal evidence suggesting the early G5s are prone to solder joint failure, particularly on the ram slots which is a bit worrisome.


I have limited experience with Macintosh towers. My experience with Macs in general comes from an iMac 600MHZ I used to have as well as a couple of iterations of laptops. I figure the absolute worst case is that I can use the machine for parts if I can't make it work, but I wonder if it's worth swapping the logic board or whether there are any potential pitfalls I should be aware of?


Edited by TheGrandPubaa
Link to comment
Share on other sites

We used to run a bunch of these at a place doing video rendering and editing I worked at some years back. In addition to the suggested failures already mentioned, I'm recalling that there were problems with GPUs failing. Oh, and flaky power regulation (likely from the bad caps).


Not going to be much more help than that, I'm afraid. When one would die, we'd typically skip trying to repair it and just replace it with an Intel-based Mac.

Link to comment
Share on other sites

My replacement RAM arrived sooner than I expected so I was able to try it in the Power Mac G5 today. Same issue, single blinking light every five seconds. The seller on eBay has 100% and stated it was pulled working from a machine, so I have little reason to doubt the RAM is good. Scouring around, I have noted a common RAM-related issue regarding a BGA memory controller chip. Fixes/workarounds I have seen referenced include blasting a certain area of the motherboard with a hairdryer and even attempting a reflow in the oven. I suppose I could also try and track down an inexpensive logic board, but chasing down that path seems kind of redundant and pointless.


I am reading up on oven reflowing because I have very little to lose with this hardware given the tiny amount of money i've put in so far(less than $15). I don't want to be careless or stupid about it, though, of course. If anybody has any tips on using a consumer oven to do a motherboard reflow, it would be more than welcome.

Link to comment
Share on other sites


Personally, I think that would just ruin it further.

I've seen anecdotal evidence over the years suggesting reflowing "can" work in "some" cases(PS3 motherboards, in particular, have lots of anecdotal evidence pro and con), so in my mind, there is a non-zero probability that it might improve the G5 situation. I will admit it does seem unintuitive, though.


Barring that, I have a large paperweight that makes a light blink and a fan spin, so I think it's worth exploring at least. Thanks for the link.

Link to comment
Share on other sites

Just a quick update. I removed the logic board and reflowed the solder on two of the ram slots with my iron(368 pins, good grief), and after going back and cleaning up any shorts, I tried booting the Power Mac to no change in behavior. I even went so far as to get a cheap hair dryer and attempt the heat workaround i've seen others have some success with(the logic is that you heat up the area around the ram slots to temporarily re-establish enough of a connection on the memory controller chips to allow the system to boot at least past the memory check), but that seems to have had no effect. I tried various combinations of the old RAM that came with the system and the two used working chips I bought, but still nothing. Nary a sausage.


So that sucks, but I guess it isn't unexpected. Chasing down the cap replacement rabbit hole seems to be more trouble than it's worth(despite my having reflowed the RAM slots, but at least that didn't cost me anything but time). Reflowing in an oven seems fraught with peril, as would be trying to reflow with a heatgun(which I don't actually own).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...