Jump to content

Apple IIe Wont Boot, Controller & Drives Working

Chris Thomas

Recommended Posts

Hi, I have an odd issue with an Apple IIe I bought about a month ago. It came with a working Disk II drive, and a controller that I was told by the seller that only worked on Channel 1. As a response to this I ended up getting 3 more controllers (dont ask). And after using all 3 to trouble shoot each other, I got 3 working fully, and ordered some chips to fix the 4th (not the original). To test, I am using a floppy Emu unit, with diagnostic disks on, and the Disc II drive, for channel 2.

So the chips turned up and I swapped one into the broken card. Tested, nothing, so I took some chips out of the other cards, swapped in, and re-seated the new chip. Turned on the Apple and It did not power up correctly. The power LED on the mboard pulsed, and the keyboard light flickered. I checked the card and found that the new chip had not inserted one entire side of its pins, with the other inserted correctly. Erk!

So I re-seated the chip, and tested again, and the floppy Emu booted. Phew. Back on solid land. At least I thought so, but...


I then plugged the Disc II into the second channel on the fixed card. Booted. and Now the Floppy Emu unit would not boot, showed an error. Turned off, removed drive from channel 2, booted, fine. How odd. I thought, OK, there must be a deeper issue with this card, not just the one chip was faulty. 

So I now try the other 3, tested working cards. Same probem. So, now I removed the Floppy Emu from channel 1, and plugged the Disc II drive into it. And booted. Drive spins up, but never boots into the game. I tested this with 3 known working floppies.

So.. to get the authentic feel of the Apple IIe I had bought Duo Disk unit. Which was shipped as working, but I had not tested it yet. So it came with an IO controller. I plugged this in, removed the Disc II controller. Same issue, physical drive spins, but it never boots.

Now, some more supporting evidence.

With the Duo Disk unit, I received a spare Apple Serial Card. So I tested this with (ADTPro) at least, that was the plan. I booted my PC, connected it to the card, made sure the cards dip switches and modem config were the right way. Plugged in, booted. Typed IN#2, pressed enter. And instead of it just going to another prompt. Instead the cursor went to the top of the display, and when I pressed CTRL + A, which would put it into serial connection mode, nothing happened.

So, now I knew something REALLY odd is going on. I put my original KNOWN working Apple Serial Card in, and tried the same. Same issue, it does not work, as it had before.

OK, so...


Has anyone else encountered issues like this? The machine works superficially. I tested the ROMS, CPU and Memmory, all good. It runs at least the Diag software fine, from the Floppy Emu. But, I now CANNOT boot ANY physical floppy drive, and I cannot use the serial card.


Further diagnostic info. I tested the Duo Disk unit in the Diag software, it showed an error, saying the drive speed was wrong. When I tested its speed, it showed it being between 295 to 298 RPM. The correct value being 300. I then tested my Disk II unit. It was kind of worse, no errors, or anything showing. And when I tested its speed, it would not show.

So my guess is... when I put that chip in, in one side of the socket, but totally missing the other, something shorted, and damaged my PSU. Because of this, it is now running, but outputting the wrong voltages, maybe.. Im getting a Multi-Meter this weekend, So I'll be able to test this idea then.

Alternatively, some chip, or other element, that powers the cards slots, is damaged, and this is delivering wonky power, to low, too high, who knowss. Its really odd that the machine seems to work in general, it processes, no memmory errors. But, both serial AND floppy drive units do not work, even though they are receiving power.


Please, any help most appreciated.


And my back story is. I neved originally owned an Apple II. Im from the UK, so I had an Atari 2600, then Dragon 32, then C64. The Apple II was too expensive in the UK at the time. But.. In 1985 I got a C64 floppy drive, plus £100 of games (it was s bundle) and one was Ultima III (Exodus) which I loved, and I never got to play Ultima I and II. So, I decided to get a real retro machine, BUT one I never actually had, and to try out the original Ultima I, II and III, as they were all developed on the Apple II.


Link to comment
Share on other sites

Is this a PAL ~240VAV //e, or an NTSC system that you adopted?


I would suspect current here, too; however you stated that your Floppy Emu did boot; and you didn't follow up on if it still boots from that device. The serial card, if not a current issue, could be a configuration issue. What specific errors did you encounter trying to use it?


You have stated a few times 'known working X'. Do you have another known working system? If so, then a direct PSU swap would tell you quite a bit of what you need to know. 


Keep in mind that the //e powers all devices attached to it. If the PSU isn't delivering enough amperage to run those devices, they could fail; but it could be delivering enough current to power the mainboard itself. If you can find another PSU, that would be the easy way. (The Europlus PSU should be identical.)


If not, then it is off to conversion city, or a PSU rebuild, to test beyond this initial diagnostic stage. 


P.S. Drive speed on the DuoDisk being slow, especially on Drive 2, was common to help bit copying. 

Edited by GameGeezer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...