Jump to content

Ultimate 1MB, Incognito, SIDE, 1088XEL/XLD U1MB Firmware 3.10 Released

Recommended Posts

I am pleased to announce the release of version 3.10 of the Ultimate 1MB, Incognito and SIDE firmware, incorporating the recently released SpartaDOS X 4.49, and version 4.0 of the SDX 'soft-driver' for SIDE, MYIDE, and Colleen. Updated APT tools and user documentation are also provided.


What's New


As well as several minor bug fixes, this release brings with it numerous performance, stability and usability improvements. Some highlights:


  • Loader's recursive search speed improved by 25 per cent.
  • Optional keyboard/joystick acceleration feature in loader speeds up navigation of long directories
  • Long filename extensions now remain on-screen even while filename is scrolling left to right
  • Card hot-swap reliability improved
  • Card compatibilty improved
  • ATR swap button now works in loader
  • Loader issue with SD/CF adapters fixed
  • Stereo POKEY detection now compatible with SimpleStereo v3
  • ATR swap button can now be disabled on the Incognito
  • Better boot drive handling (fixes issues with some boot loaders run from FAT-hosted ATRs)
  • Improved DCB error checking in PBI BIOS and support for immediate-mode IO
  • XF551 high-speed SIO bug fixed
  • Regression regarding CONFIG.SYS boot drive setting fixed
  • FDISK large volume/disk bug fixed


Please see the changelogs for the main BIOS, PBI BIOS and SIDE Loader for a complete list of changes.


To download the updates, please visit the atari8 firmware page.


SDX 4.49


Thanks to DLT, we have the welcome release of SpartaDOS X 4.49. Unfortunately the ROMs hosted on the official SDX site were put together before I released the updated APT tools and SDX soft-drivers. As ever, however, SDX ROMs for all platforms are included in the new firmware release, with the extra tools I like to provide (notably the LSDEV and LSDSK utilities on the CAR: volume). Note the plethora of ATR disk images I provided in prior updates has been done away with; all ROMs for U1MB and Incognito are included on the corresponding 'FIRMWARE.ATR' disk image. This makes the preparation of subsequent updates a little less labour intensive.

Please look at the updated README files in the ZIP archives for complete descriptions of the archive contents.


I hope you enjoy the updated firmware and tools, and as always I welcome feedback including bug reports and feature suggestions (although we are rapidly reaching the end of the road when it comes to available code space on the existing hardware). Donations are likewise welcomed and appreciated, although they are by no means obligatory.


Special thanks to Lotharek at lotharek.pl for his continued provision of Candle O'Sin's fabulous U1MB, SIDE2 and Incognito devices, and for offering my firmware pre-installed at the point of sale. Please continue to support his invaluable efforts and accept no substitute.


As usual, please use this thread to discuss any issues so I can address them as efficiently as possible. Since there is barely any code space left, the idea here is to have a milestone release with no known bugs. All issues known about since version 3.02 have been addressed, but since there have been a fair amount of changes and additions, there's always the possibility of another minor point release. We shall see. :)

Edited by flashjazzcat
  • Like 11
  • Thanks 14
Link to comment
Share on other sites

40 minutes ago, bfollowell said:

but it sounds like a lot of improvements

I was surprised the list wasn't longer given the amount of time spent working on it, but quite a lot of the effort was focused on improving existing functionality rather than implementing a lot of new features. Hias' recommendations regarding DCB buffer length checks prompted quite a lot of changes and were most useful in exposing some sloppy DSTATS management in one or two of the tools. Thereafter came the news that the stereo POKEY test didn't work with SimpleStereo v3, and a few issues I ran into while doing my own tests or (as usual) making videos intended to show off the firmware. :)

Edited by flashjazzcat
  • Like 5
Link to comment
Share on other sites

The 256K SDX ROM in the U1MB package is bogus (version 4.49c). Thanks to Eyvind Bernhardsen for pointing that out. It's not really used anyway, but I'll replace it with the correct version in the morning. There was no 256K U1MB ROM in the official SDX package and I clearly made an error when cooking one up.

Link to comment
Share on other sites

14 minutes ago, flashjazzcat said:

1088XEL/XLD and U1MB archives now have corrected 256KB SDX ROMs

So as it happens, I had just finally gotten around to updating my Incognito 800 and 1088XLD to the SDX 4.49 final version just about two days ago. I had forgotten the fact until it came time to update, but my 1088XLD was indeed using a 256KB version of SDX, I guess because I have your GOS work in progress installed as well.


Going from memory here, If I decide to put the larger SDX installation into my machine, UFLASH will require me to set a larger size for the SDX slot, correct? 

Link to comment
Share on other sites

24 minutes ago, DrVenkman said:

I had forgotten the fact until it came time to update, but my 1088XLD was indeed using a 256KB version of SDX, I guess because I have your GOS work in progress installed as well.

The GOS takes 128K of ROM space, so if the 256K version of SDX is also installed, either the back-end of SDX got wiped out, or the first half of the GOS. In general, use the 192K SDX (if you want the GOS present) or the 320K SDX (if you don't).

25 minutes ago, DrVenkman said:

Going from memory here, If I decide to put the larger SDX installation into my machine, UFLASH will require me to set a larger size for the SDX slot, correct? 

Correct. Options->Set SDX Size. You can pick 256K there if you want and the GOS slot will be deactivated, just as per the 320K option.


Stand by for a re-upload, however, as I just discovered a purely cosmetic but f***ing unbelievably exasperating error. :) Details to follow when everything is ready.

  • Like 3
Link to comment
Share on other sites

OK: typo fixed on the loader's Options menu. Must have hit the delete key when editing the source code or something and never noticed till today. I beseech everyone to update (Incognito users need only reflash the loader ROM)!


I didn't bump the version number but the date stamps on the ROMs in the ATRs are 25-04-20 and the revision date in the loader binary has also been bumped.


Edited by flashjazzcat
Link to comment
Share on other sites

I have downloaded the files for SIDE2, Incognito and U1M, on my 130XE I've flashed U1M

however I don't seem to be able to flash the SIDE2, I select Device->Open and change device to SIDE2

and it says Device not present.


I tried with PBI disabled and SDX disabled in U1M, then booted from SIDE2 SDX, loaded uflash.xex from D1:

but it still says Device Not Present. I looked at the Doc's but it just says use UFLASH.XEX, nothing specific for SIDE2.


How can I flash the SIDE2 ?

Link to comment
Share on other sites

3 minutes ago, TGB1718 said:

How can I flash the SIDE2 ?

You should definitely disable the PBI HDD and SDX on the U1MB first and boot SDX from the SIDE2, so you did the right thing there. UFLASH should detect the SIDE2 automatically (and indeed does so here when I tested one of the ATRs I just re-uploaded).


Which disk image are you actually using? I recommend side2_full.atr or side2_full_oss_carts.atr (the latter if you want to use ebiguy's patched OSS cart ROMs), since the full flash will update SDX and the loader in one fell swoop.

Link to comment
Share on other sites

I am using side2_full.atr, I just tried again and still get Device not Present, however, I tried a second time

but select SIDE instead of SIDE2 and this time it accepts it and shows the following:-


ST395F040 (512 KB)

 |-Spartados X

 |-External Cartridge


I have not flashed, thought I would wait for your reply


Edit: Just tried in Altirra and it does the same. SIDE2 Device not Present, SIDE shows:

Device  Slot  Options  Help

|A29040 (512 KB)                       |
| SpartaDOS X                          |
| External Cartridge                   |

Edited by TGB1718
Link to comment
Share on other sites

36 minutes ago, TGB1718 said:

but select SIDE instead of SIDE2 and this time it accepts it and shows the following

Most odd. Are you sure this is a SIDE2 and not an original SIDE? SIDE1 has a banking register clash with U1MB, so it's better not to flash the older cart on an U1MB machine.


Assuming this is a SIDE2, the only reason the flasher won't find the cartridge is if there's some other ROM in the way (usually U1MB's SDX ROM). Either that, or the PBI HDD is enabled.

28 minutes ago, Roydea6 said:

If all functions work properly then I will live with a spelling error.

The fact the misspelling exists on your machine will cause me insomnia. :) Please update!

Edited by flashjazzcat
  • Like 1
  • Haha 3
Link to comment
Share on other sites

Now... I don't want to be that guy (again), but the new 256 kB image shows an error when it boots with the built-in CONFIG.SYS:

Config error (144): DEVICE COLLEEN

It looks like it's meant for Incognito not U1MB.


For the record: I use the full SDX image on my XEGS and am only playing with the 256 kB version in Altirra to see what the differences are between the three sizes. Personally, I'd just get rid of it :)

  • Thanks 1
  • Confused 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...