Jump to content

Can't get a new Harmony Cartridge working.


Recommended Posts



I recently purchased a Harmony Encore cartridge and I can not get it working for the life of me.


I put the games on an SD card and then inserted it into the cartridge and whenever I would turn on the 2600 it would just be a black screen. After searching around I found that people who had the same problem got it working again by re-flashing the BIOS so I downloaded the Harmony Software but could not get the cartridge to be recognized by Windows 10 at all. I finally got it recognized on an older Windows 7 machine and was able to re-flash the BIOS. Then when I put the cartridge into the 2600 it would show the spinning logo for a couple of seconds and then just go to a black screen. Turning the 2600 off and on repeats the process one or two more times of spinning logo followed by black screen and then after that when I power it on, it just goes straight to black screen until I re-flash the BIOS again when I can get the spinning logo to show back up a couple more times before just going straight to a black screen.


In the FAQ of the manual it says "My Harmony cartridge just displays a spinning logo on the screen, and nothing else happens - what am I doing wrong?" and lists the reason as the SD card not being supported/formatted correctly but the way its worded makes it seem like its referring to the spinning logo constantly being displayed whereas it displays for a second or two for me and then goes to black screen. In any case, I've re-formatted the SD multiple times and tried different SD cards and it's the same thing every time.


Also, I'm not sure if this is relevant but I bought the SD version (not the microSD version) and in the manual it says the SD card slot is a push-push design. I'm not sure if that refers specifically to the microSD version but the slot on my cartridge is definitely not a push-push design.


Thanks for any help. I'm so excited to take the Harmony cartridge for a spin and it feels so close, yet so far from getting it to work lol.


EDIT: Just to add a bit more info, the console itself is a Light Sixer and all the other games I've tried on it (only a handful) work no problem.

Edited by BRM98
Link to comment
Share on other sites

If you see the spinning logo then a black screen, usually it means one of the address lines is not functioning. Sometimes this can be caused by a bad connection to the cartridge port, so cleaning with isopropyl alcohol and a Q-tip is recommended. A small screwdriver or other implement inserted into one of the rectangular holes on the cartridge dust door can help you get to the fingers.


If cleaning does nothing, you may have a defective cart. PM me and I can get you a replacement.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...