Jump to content

GameDrive not booting at all

Recommended Posts

Hi -- I have purchased a RetroHQ GameDrive used, and it came with a 2GB SD card already populated with ROMs.  I just finished assembling a Lynx 2 build with the Bennvenn LCD kit after recapping / replacing power components.  It works with the one real cartridge I have, Steel Talons.  The GameDrive however only starts up displaying the INSERT GAME message, a blank black screen, or what looks like static.  I also scanned the filesystem on the SD card for errors, with no improvement.  Is my GameDrive busted?


EDIT: This is a Lynx 2 C104342-001 Rev.2 with the BennVenn solderless v6 display: https://bennvenn.myshopify.com/collections/aftermarket-lcds/products/drop-in-lcd-kit-solderless-drop-in-pre-order-revision6

Edited by rayrayrayraydog
Link to comment
Share on other sites

I did have a GD go out once in a similar fashion, apparently a very rare occurrence, but it's also possible that the connection just isn't being made properly in your Lynx II. A few SD carts (including the BennVenn El Cheapo and the Lynx SD precursor to the GameDrive) needed to be moved around a bit in the cartridge slot in my Lynx II consoles in order for them to boot up. Sometimes it takes quite a few tries, probably due to aging connectors. Cleaning didn't help. The new GameDrive never had that issue in my systems, but yours might be different.

Edited by nyandeyanen
Post-post typo spotting
Link to comment
Share on other sites

Given these symptoms, if cleaning the edge connector on the cart and re-inserting a few times does not fix the problem, it is most likely a problem with the cart.


The cart will boot without the memory card, so it's not related to the memory card in any way.


Sorry, problems like this are rare, but carts can fail between leaving me and reaching the end user! I'm not sure if being x-ray'ed on the trip is a factor, with bit flipping in the flash, or whether it's just a physical issue.

Link to comment
Share on other sites

Okay, I've carefully removed the PCB from the case and I don't see any obvious signs of damage to any components.  It's possible that this card fried when I stupidly tried the headphone jack ground on another unit before I learned how dangerous it was. 


I see three pins on the back of the PCB on the bottom.  Are these debug pins?  Is there any way I can externally try to bring the cart back to life / reflash firmware?

Link to comment
Share on other sites

  • 2 weeks later...

I've tried a different flash cart which works.  I can only assume that I fried it on my other Lynx board with the headphone jack ground trick (possibly sending the cart 9v) or it came to me dead.  Never ever use the headphone ground trick.  Oh well! 


If there is some component on the PCB that would have fried from this that I could replace, please let me know.  Otherwise it's headed to the recycler.  :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...