Jump to content

Firmware rollback - game drive freezes when loading


Recommended Posts

Hello all, new to the forum.  Excited to have received my game drive, and started out everything worked great, except CD’s.  I just received it a few weeks ago so I’m assuming I’m in a new batch from Stone Age gamer.  So I played all my roms, no issue.  OK time for CD so did a firmware update to 1.10 (via the UPC code), loaded up a few CD’s and they both froze right when the game was going to start (menus worked).  Then they stopped loading (would freeze in loading, sometimes 1/4 of the way through sometimes almost all the way done). Ok, not worried about CD’s, going back to Roms.  Same with Roms.  Memory check (9 and 7) fine.  Formatted micro SD, loaded just roms back on, nothing.  Swapped out microSD to another fat32 formatted 32GB card, first two Roms loaded fine, then back to the same thing.  Won’t load anything.  Some don’t start, some freeze somewhere in the middle.  Really weird.  Cart slot fine (checked specifically the interrupt pins).  Carts work fine (I know they don’t use interrupt but for sake of diagnosis.  

I have to think what started all of this was the new firmware.   Can I go back to I’m assuming 1.09 to rule that out?  I saw something about fixing a clock cycle at some point, maybe I need the old timing.  My Jaguar was a launch Jaguar (I remember leaving my college campus to drive up to the mall of Memphis to buy it)!


thanks for any help!

Link to comment
Share on other sites

If it's helpful, I have some more diagnostic information.  I ordered a 16GB microSD, loaded it with fresh roms, plugged in and it worked great for the first load.  Rebooted to try another game, no progress on the progress bar (freezes).  Again and again, same thing.  The only way to get it movement on the progress bar is to power off, remove the GD, eject and re-insert the MicroSD.  Then when I try to load, it worked the first time (with another ROM) and then back to nothing.  Powering off, removing the cartridge, ejecting the MicroSD and re-inserting, gets the progress bar moving again.


I don't really think this would be it, but is there a key combination on the controller to shut down or exit a loaded ROM?  Wondering if powering off the Jaguar leaves the microSD in a non-removable state?


Appreciate any help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...