Jump to content

Freezes after "Loading ROM..." progress bar fills


Recommended Posts

Hello, I just received my GameDrive today, and can't get it to load any ROMs. It appears as though it's loading them, the progress bar fills in the whole way, then nothing.


I've tried 2 different SD cards, one being a 32GB PNY branded one, and an 8GB SanDisk brand, both with the same result. I've tried formatting them and copying the files on both PC and Mac, even trying the long format instead of quick on Windows. I started out trying ROM sets of .j64 and .jag and then sought out the "preferred" ROM/images set, also with the same result. It passes the memory test. I've cleaned the contacts with WD40 electronics contact cleaner and went over them carefully with a toothbrush. My cartridges generally load fine.


I figured I would start a new thread since I couldn't find other threads mentioning this specific kind of behavior- it freezes after the loading bar progresses and not before like I've read about on the other threads, and I don't get any kind of red screen.


One thing that may or not be be relevant is that I have also been unable to get my Jaguar CD to work as of late, which worked fine for many years. It powers on, the laser bumps around a little but the disc doesn't spin at all, and it will say that there's no CD inserted. The CD lid switch tests out fine, and overall I'm figuring the motor is trashed on it. I thought it might be worth mentioning since I've read about some cartridge port pins being potential issues.


Any help is appreciated!





Link to comment
Share on other sites

The only thing the cart does after loading up a ROM is reset the console. Nothing else (not even the JagCD I don't think) uses the reset input connection (B33, RESETIL) on the cart edge, so your console could otherwise work perfectly but still fail with the JagGD in this case. While your cart edge connector doesn't look like it has any bent pins, it does look a bit crusty. My money is on there being a fault on this pin connection somewhere. As always, if it's possible to test on a 2nd console somehow, that will quickly narrow the problem down to either the cart or the console -- my gut feeling is that it's the console currently.


Cartridge Connector Pin Out

Link to comment
Share on other sites

Unfortunately, I do not have a second console to test with.


I've taken the Jaguar apart and carefully cleaned the cartridge contact pins more with some fine sandpaper. Everything loads great, except for the GameDrive.


However, I cannot find continuity anywhere on the board for that particular pin (B33), and the traces are way too damn small for me to follow. Does anyone with more detailed knowledge know of a good place on the board to check for continuity for this pin?


With the console powered on and stuck at that loading step, would momentarily shorting out B32 and B33 effectively reset it, as a test?

Link to comment
Share on other sites

Actually, nevermind, I got it working!


I went over the board with a digital microscope and found some of the traces to be in terrible shape, and found at least 1 broken one that needed fixed, but this still wasn't enough to get the GameDrive to work. Then I came across this post: 



I checked for continuity between the place shown by the "MOD" text and B33 and had nothing, and also noticed this trace was also rather terrible looking from what I could see of it before it goes under the cartridge port. So, I soldered a small jumper wire between the 2 points, and it's now working! :)


  • Like 3
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...