Jump to content

Both love and hate my //e


Recommended Posts


Seems like there is always something.  

I finally saw a CP/M card online for a price I was willing to gamble with.

OK, now I need to make a CP/M boot disk...

Been a while since I used my //e to write disks, but the PC is still there nearby.  Serial cable is ready...

Hook it all up, launch ADTPro (on the PC and Windows) and... Can't read the directory.  Timeout...


Try a bunch of things (the //e isn't somewhere I can easily really work with it unfortunately) and get nowhere.


Finally fall back to audio...  Try that, and doesn't work...  To be fair, not sure I ever tried that in ADTPro...


Hmm  Go to the Apple Disk Server (there is a CP/M image there, tho not sure if it is the right one...)..

Try that with audio, it starts to work, gets to the format step, and fails...


Hmmm...  That's a (basically) new floppy I was trying...

Try another one, same thing...  Hmmm.

Go to ADTPro to try to preformat the disk.. error...  Try again with other disks, error..

Both drives, won't format...

CopyIIPlus says the disks are right protected, but not sure how accurate that error is...


So, I'll have to move a lot of things around so I can open things up and really work on this guy to see where my error(s) is (are)...


The Duodisk is still booting floppies fine.  Just can't format anymore (I haven't tried saving something yet).  And I don't think that is my ADTPro issue, as I couldn't pull a directory from ADTPro, which doesn't involve writing...  So probably two different issues?


Oh well, retro... Always something... ;-) 

Last thing I think I did (awhile ago) was add a Booti card, so I might try removing him just to make sure that isn't conflicting in some weird way.


Edited by desiv
  • Like 1
Link to comment
Share on other sites

And it's working again (and of course I love my //e again)... ;-)


It was two issues, both related to the awkward location my //e is sitting at right now.  

At least I think both related.


As for the disks not formatting, after I pulled to //e out and checked some things (and found my other issue) and put it back together, I could save and format again.

So I am thinking maybe the duodisk cable might not have been tight or ???  


The other issue was what was keeping my ADTPro from working.  It looks like when I plugged in the DB25 the last time, one of the pins bent over a bit.

Fixed that (which required pulling the machine all the way out of where it was) and it just worked.


As long as I had it out, I plugged in the CP/M card and tried it and it works (56k?  I am assuming that is working fully.  I have to read up on Apple CP/M (Microsoft card).


What it really shows is that I REALLY need a better location for the //e.  But it's just so large, it doesn't really fit in my office well...

I also realized I need to make a new audio cable for my Mockingboard.  The way it is sticking out from the card, the cable is pressing against the CP/M card.

Not badly, but I think I need to make an angled 4 pin header for it just to make it happier...  ;-)

I honestly would hate it if these computers just worked every time I turned them on.

But when I get something new to test, I want them to work THEN!!  ;-)

Edited by desiv
  • Like 1
Link to comment
Share on other sites

21 hours ago, desiv said:

As long as I had it out, I plugged in the CP/M card and tried it and it works (56k?  I am assuming that is working fully.  I have to read up on Apple CP/M (Microsoft card).


56K free RAM sounds about right, if I recall correctly.

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
4 hours ago, cbmeeks said:

Yes, always something.  Pulled my IIe out this evening and discovered some keys don’t work.  Worked when I put it away a few months ago.

Perhaps generalized light oxidation that has added up over time..? And just that little bit more pushed it over the edge.

Link to comment
Share on other sites

Well, I think it was more than that this time.  I pulled the switch out and even took it apart, cleaned, etc.  But no matter what I did, when I would reassemble the switch, it wouldn't work.  Plus, some of the plastic was so brittle that it started snapping off.


So I just found another switch on eBay and it actually arrived yesterday.  I got it soldered in and now it works.  But who knows which key is next.  🙂


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...