Jump to content

commodore 128DCR stuck after COMMODORE BASIC 128 banner no ready prompt


Recommended Posts

Hi a few days ago a friend of mine dropped his non working commdore 128DCR to get some help fixing it.
The computer don't worked in 128 mode the keyboard typed random garbage.
So i replaced the ROM U34 for an eprom (128 basic) and socket both CIA's U4 and U1 replaced them.
This fixed the keyboard issues and the not working 128 mode and now the basic banner shows up in 128 mode.

The issue is that the banner "commodore basic v7 ...." shows but there's no ready prompt.
Read that this can be caused by a bad internal drive so found that cutting pin 1 from U113 disables it the internal drive have a broken head anyway.
Doing this don't changed anything still stuck after banner no ready prompt.
In 64 basic if i try to load from an external floppy drive tried device 8 and 9 nothing computer freezes and there's no activity on the drive.




  • Like 1
Link to comment
Share on other sites

I have only had to troubleshoot a 128 once, and that was decades ago.  My first instinct tells me RAM and CIA.  The latter has been covered, it seems, and the amount of BASIC RAM free seems to cover the former.  Will the system boot to CP/M?  That would eliminate the disk system (computer interface and disk drive) as a culprit.  Good luck.

Link to comment
Share on other sites

  • 1 month later...
On 8/9/2023 at 12:46 PM, soviet said:

Running the computer having U112 removed gets all working fine, of course the internal drive is disabled.
Planning to use the C128 using an external drive so don't care about the internal one.

Thanks for all the help.


It is good if you haved solved your problem.


For other people: In many cases.... Check all socketed chips and press to make sure none of them are slightly unseated. That's a start. Check to make sure there is no broken solder connections on things like the keyboard port and such. It maybe the BASIC lo ROM chip either faulty or not seated properly. Reseat the ROM chip and see if prompt shows up. If necessary check all ROM chips and be sure seated right.

Edited by Wildstar
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...