Jump to content

Apple //c with ROM ver3 with FloppyEmu (recent FW) connected directly to internal floppy port on the mobo. Can boot 5.25" disk images but can't seem to boot off of any Smartport image files. Any tips?


Recommended Posts

I've tried several disk images from http://apple-2.com/?i=1 and of course the super popular Total Replay.   Some points:


  • FloppyEmu is on a 2023 firmware
  • //c has a bad internal 5.25" floppy drive
  • FloppyEmu is able to boot 5.25" floppy images via plugging directly onto the motherboard in place of the original floppy drive
  • Have tried soft and cold boot after disk images have been selected (see photo)
  • Older help posts and firmware would have me rename the disk images to smart0.2mg and have it at the root.   Also doesn't work.


It seems some people manage to boot to the internal floppy first with some DOS and then use it to select the boot file on the mounted disk image but this isn't an option for me bc of the dead int drive.   Some people boot to another ProDOS hard disk image but I'm unable to boot to any HDD image.



Screen Shot 2023-11-17 at 10.49.13 AM.jpg

Link to comment
Share on other sites

My guess is that the //c rom doesn't expect a smartport device as the first device. It probably expects a 5.25 drive. A smartport device would normally only be connected to the external/drive 2 port. Basically, why would it try to boot a smartport device from drive 1 when drive 1 should always be a 5.25 floppy?


Pretty sure that's how my rom4 works (but it's been a while since I booted that with a smartport device). It spins the internal drive first, and if nothing is found in the drive, it then looks for a smartport device in the external port. 

Edited by nick3092
  • Like 2
Link to comment
Share on other sites

  • 5 months later...

To boot anything other than 5.25 disk imageds you need to unhook the FloppyEMU from the motherboard and plug it into the the external smartport on the rear of the computer. Then as Chrisa850 said once you turn on the computer, if you get the Applesoft prompt, type PR#5 and that should boot the FEMU. If you get the check disk drive message press and hold open apple-control and then press and release reset, otherwise known as the three finger salute. That shoul boot the computer from the FEMU.

Link to comment
Share on other sites

  • 1 month later...

As @nick3092 and @magnusfalkirk indicated, the Apple IIc can only boot SmartPort based disks/images from the external port, while the internal is only useful for DOS or 5.25" disks/images.

As well, the external port is only useful for SmartPort based drives; due to it is intended for the Unidisk 3.5" , an external 5.25" drive doesn´t work in an Apple IIc, unless you replace the external 5.25, with the internal 5.25 one.


Its a limitation of the Apple IIc; there is a workaround to switch internal/external drive:





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...