Jump to content

Colecovision Graphics Problem.


Recommended Posts

Hello All,


I just got my new-to-me Colecovision working, and it has a problem. There are horizontal lines in blocks down the right side of the screen. The lines only appear in game and not on the title screens or player select menus. Some games behave differently. Mouse Trap has a series of symbols down the right side, and Donkey Kong has horizontal lines spread throughout the levels.


When I first got the CV the PSU that came with it blew the 4700uF capacitor a few minutes after plugging it in. Thankfully, the PSU wasn't connected to the CV when it blew up. I'm now using a Mean Well PSU and a Lundy Electronics adaptor. I have no way of knowing if and for how long the previous owners might have run the CV on the dodgy PSU.



So, what do you think? is it a power problem, bad RAM or something else?






Link to comment
Share on other sites

   I noticed on the title screen of my CV that there are dots after V, S, and O that don't belong. So I downloaded the service manual and began working the troubleshooting flowchart for a scrambled logo screen. I pulled my old Kikisui 60MHz oscilloscope out of storage and began poking around. This video showed me what to do.


   I checked for data on U9 pins 25-32 and they all appear to be active. Next, the flowchart says to check U1 & U2. I haven't got to U2 yet, however, while testing U1 I found no signal on U1 pin 17. I have roughly 5V on that pin with a tiny bit of ripple, but nothing resembling the signal shown in the picture at the end of the manual. If I found the correct datasheet pin 17 is the NMI, which is an input? I don't yet know where the NMI signal is supposed to come from, and I don't know how to fix it. Does NMI have anything to do with my problem?


While testing I kept an eye on the DRAM temps and, according to the thermocouple on my DMM, the chips are all running between 105 - 110 degrees Fahrenheit. 


I picked up a copy of Miner 2049er and it shows the worst graphical defects.





Link to comment
Share on other sites

as you have moved to another power supply i would say that isn't the issue


i would try cleaning your power switch contacts first, unfortunately this requires some de soldering and disassembly of the switch, but is a lot easier than trying to replace the video ram.  if the switch is clean or the issue still remains upon cleaning the switch contacts, i would think the next stage would be attempting to replace the video ram with 5v counterparts

Link to comment
Share on other sites

13 hours ago, omf said:

i would try cleaning your power switch contacts first

Thanks, I did clean the power switch before doing any other testing. I bought a de-soldering kit at my local Harbor Freight. The pumps made short work of removing the switch, although I had to carve the thick tip into a cone shape to fit between close IC pins. 


13 hours ago, omf said:

i would think the next stage would be attempting to replace the video ram with 5v counterparts

I would think Ram is the problem too. I had similar issues with one of my Intellivisions and replacing the RAM fixed it, but as I mentioned I have data on U9 where I'm supposed to have data. However, I have not tested the RAM directly yet.  For reference my CV uses Mostek mk4315n-3 chips. Console5 is out of stock for their 5V RAM kits. When I shop around for 4164's or 4516's there are always different dash numbers at the end of the part number, and I don't know which ones to get. I think the dash number refers to speed. Would it matter what speed I get as long as they're all the same?

I'm still going to poke around with my ancient Kikisui and see what I can learn.

13 hours ago, omf said:

as you have moved to another power supply i would say that isn't the issue

The original power supply gave me the same problems this person on Reddit was having. Donkey Kong looked exactly the same as his pictures.

Link to comment
Share on other sites

Just now, nick3092 said:

If you are looking to do the mod to change out the dram, why not just replace it all with sram?



Right now, it's mostly cost. I paid more for my CV than I wanted to, but it was complete and came with a few good games. Then having to spend ~$80 on a new power supply setup has got me feeling the pinch right now. Plus, a little intimidation of having to make such a dramatic looking change to the motherboard.

Link to comment
Share on other sites

So, I've checked all of the RAM chips and they have the correct voltages, there is data going in and out, data on all the address pins. I'm not convinced the RAM is bad. However, I have found the signals are all messed up on U22. U22 pins 3,4, and 8 are supposed to be checked at 1V/div and 5uSec/Div, but the signals are a blurry mess. I don't get a good image of the signal on the scope unless i set it to .05uSec/Div. Can anyone confirm there's not a typo in the service manual? I'm thinking U22 might be bad, but I'm not yet sure if the chip is bad or if it's getting bad input. 


Anyway, I'm still working on it.

Link to comment
Share on other sites

  • 2 weeks later...

I think I got it fixed. 

TLDR: U17 was bad, and I did the 5V RAM mod.


Ultimately, I did the 5V RAM mod, but first I desoldered the 12V RAM and installed sockets. After that I reinstalled the 12V RAM back in their original places and made sure the CV worked as before. Once I verified the CV worked, I went on to swapping around RAM chips to see if I could make the errors change position on screen. What I found was U17 was causing the bulk of the problems. I think one other chip might have been bad as well because of some dots on the screen, but I could not get them to change position no matter what RAM chips I swapped around into different sockets.


After isolating the bad RAM chip for "science," I finished the 5V mod and installed MOSTEK MK4516N-15 RAM that I found on ebay for cheap. The graphics are as good as I'm going to get with RF, and I can't see any other graphics problems. The only thing I don't like is the games feel like they're running a bit fast. What I mean is the barrels in Donkey Kong are rolling faster than I think they should while Jumpman is moving at what feels like a normal speed. I have no reference for what is normal other than playing DK on my 2600 or Intellivision so, I might be worried about nothing.


I know I said I wasn't sure the RAM was bad, but it really looked like bad RAM was causing the graphical errors. I asked for advice from more experienced people, and it came back RAM, so I wasn't going to ignore that either. Just because I had data on the address lines doesn't mean it was the right data. "If it looks like a duck..."


Thank You Everyone.


P.S. How do I mark a topic as solved?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...