Jump to content

TI-99/4A - Some keys not working.

Recommended Posts

Hello, I've recently acquired my first TI-99/4A computer (black & silver).  It turns on OK, I get title screen and can get to TI BASIC, but the following keys, when pressed, do not show its character on the screen:
0 (zero)
= (equals)
; (semicolon)
. (period)

...pressing shift while pressing these keys doesn't do anything either.  All the other keys work fine.


I opened the TI and disconnected the keyboard, and the traces look OK.  I did a continuity check for each problem key switch.  For example, I set my multimeter to 200 ohms, I connected the two multimeter leads to the key switch posts for the zero key, then I pressed the zero key...and I get 6.3 ohms.  I tested a few keys that work and they get around 6.3 ohms as well.


Therefore, that makes me think that the key switches are OK, and the next thing to check is the ribbon cable.  The cable looks like it's attached fine.  I did a continuity check on each of the 15 pins on the PCB to the corresponding female end of the cable (that plugs into the header on the motherboard)...and each of the 15 pins checked out OK.  Then using the keyboard grid schematic (see pic) where it lists what key activates which two of the 15 pins, I tested a few keys that I know worked.  For example, I connected my multimeter probes to pin 5 and pin 9, then I pressed the "N" key, and I got a reading of around 8 ohms.  But when I tried the same process on the problem keys, they all failed--no reading.  For example, for the zero key, I connected my probes to pins 2 and 8, then pressed the zero key--I got no reading.


Here's what's weird.  I tested again, but instead of pressing the key, I shorted the key's two posts with a small screwdriver.  Then I got a reading!  That doesn't make sense...does it?


Any idea what the culprit could be?  Could the key switches be dirty?  If so, can they be cleaned?  I removed/desoldered a key switch from the PCB and it doesn't look like it can be taken apart.  It's a Futaba keyboard with two-post key switches, the top of the switch assembly is square but the rest is round (see pics).

TI994a keyboard matrix.png



Link to comment
Share on other sites

That suspiciously sounds like either dirt or bad clearances inside the switch (the problem symptom will usually be the same for either). One way to test for that is to select the key 40-50 times in a row to see if the movement clears the problem for that key--as that will often clear a dirty set of contacts. Other than that, you "could" try disassembling the key switch to clean it, but I have never done that with the Futaba switches, so I can't give much advice there. Most of the other mechanical switches have the contacts conveniently visible once the key cap is removed, so cleaning them is pretty easy if you are gentle about it.

  • Like 2
Link to comment
Share on other sites

Thanks Ksarul.  Yeah, these Futaba key switches don't look like they can be disassembled.  I sprayed some DeoxIT in them when I first discovered the issue, and today I sprayed them again and pressed them over 50+ times and still no luck.


For my testing in my first post, I connected the two multimeter probes to each respective [female] pin in the cable (e.g. pins 2 and 8 to test the zero key), then pressed the key, wrote down the reading (if any), then shorted the two key switch posts with a screwdriver and wrote down that reading.  I'll call this Test Config #1.


I did some more testing and it's getting weirder.  This time I did the config in reverse.  I connected the two respective cable pins with a single jumper wire (e.g. pins 2 and 8 to test the zero key) and connected the multimeter probes to the two posts on the zero key--I'll call this Test Config #2.  As I expected, I got no reading when no key was pressed, but when I pressed the zero key, I got 4.2 ohms.  When testing the same zero key using Test Config #1, I got no reading when pressing the zero key...not sure why the two tests gave different results.  Then I tested a working key--the number 9 key (using Test Config #2).  When I connected the jumper wire to pins 2 and 13 then connected the multimeter probes, I GOT A READING of 6.2 ohms BEFORE I pressed any keys!  Then I pressed the 9 key and got a reading of 5.5 ohms.  So what is going on?  Are there some resistors on the keyboard PCB?  I know there are some jumpers to connect some of the traces.


FWIW, I did notice that a post on the FCTN key has its PCB pad beginning to separate from the board, but the FCTN key works when I tested it with the TI turned on.

Link to comment
Share on other sites

I suspect you may have to replace the key switches that don't work with donors from another problem keyboard with the Futaba switches.


One note: stay away from any Mitsumi keyboard (most have the beige keys, but there are some with black keys as well). The Mitsumi keyboards used a membrane for key contact. It was the best thing out there when the keyboards were new--but the membranes did not age well and are a serious pain to rejuvenate/repair. Quick tell on Mitsumi keyboards: the bottom of the circuit card is brown and has no visible solder points.


There are no resistors on the keyboards either--it is a straight matrix arrangement. Not quite sure what is going on there.



Link to comment
Share on other sites

Ugh, I think I was over-caffeinated in my previous post.  Of course, when using Test Config #2 on a working key I get a reading without pressing the key.  I think the telling issue is not getting a reading, which is what happens when testing the non-working keys.  At this point it looks like the culprit is a broken/bad trace or cold solder joint on the posts of the non-working keys.  I'll have to look much closer at the traces or re-solder the posts on the non-working keys.

Link to comment
Share on other sites

Did some more testing and was able to isolate bad posts on each of the problem key switches.  I think the pad-to-trace contact is problematic on these switches.  Earlier, when I removed a keyswitch in the photo above, one pad came off.  Then when I removed the old solder on the problem posts, every one of those pads came off as well.  That may be why they were bad--the pads were separating from the PCB/trace contact.


To fix it, I scraped off a little bit of the solder mask (green coating) of the trace where it comes into contact with the pad.  I put the pad back onto the post and soldered it, while also getting solder onto the trace.  I did that to the four keys that weren't working, and now they work!  Woo-hoo!

  • Like 5
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...