Jump to content
IGNORED

Vectrex Won't Power On After Storage


Silverfleet

Recommended Posts

I've been renovating my house for the last year, and all my stuff has been in storage during that time, including my game collection. Last weekend, I got the go-ahead to start setting up my game room again, and one of the first things I unpacked was my Vectrex. I was SUPER careful packing it, wrapping it in bubble wrap and all that, knowing how fragile they are. When I pulled it out of its box, I figured I'd get in a quick game of Mine Storm to take a break. 

And... nothing. 

Power switch doesn't seem to do anything at all. No humming while plugged in, no monitor signal or dreaded white dot; just nothing. 

I've read somewhere that the power switch pots go on these all the time, but it seems odd that this would be the issue, since it's just been sitting idle for a year. It did work before I put it in storage, too. 

Once I get my work bench set up, I was planning on pulling the back off and seeing if something went wrong. Where should I start with the diagnosis? 

  • Sad 1
Link to comment
Share on other sites

Damn, sorry to hear that. Same boat, house reno past year but we're still not back in yet. I put my 3 Vectrex consoles in storage along with the rest of my collection.

Link to comment
Share on other sites

  • 2 weeks later...

Quick update: I got it working again!

I did some research, and lots of people said to try some Deoxit on the power/volume pot. So I ordered up a can and got to work. When I pulled the knob off, there was some junk in there, so after cleaning what I could, I hosed it down with the Deoxit and worked the pot back and forth a bunch. I plugged it in, and nothing. So, I repeated the process a few times. Then, I got the "white dot" on the screen. Not what I wanted, but a sign of life! I repeated the process a few more times, and it eventually came back around. 

mQMnzjhl.jpg

Some adjustments to the brightness, and it was good to go! 

tyuNtnQl.jpg
Both Minestorm and my carts play well now. The controller definitely needs some cleaning though, as you have to really jam on the buttons to get them to respond. 

b7cZo6Hl.jpg

Deoxit for the win! 

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

Congrats on getting it working! ❤️ 

I'm guessing though that the Deoxit did not fix it (if you were only spraying it down the shaft from the front), but rather just turning it on and off many times did.

 

If you look at how the switch is constructed here:


You can see that there is quite a long path to get from the shaft, through the potentiometer housing, and into the switch housing.  Then to actually touch the switch contacts, a lot of deoxit must fill up this area back there.  And then, a bunch more time would need to pass for all of that deoxit to evaporate out of there before turning it on.

So it was probably just the "wiping" of the contacts many times that cleared off the oxidation.  When you switch the vectrex on and off, when the contacts come together, some friction is imparted on them and it can help to keep the contacts clean (aka wiping)... just by turning on and off the vectrex.  For this reason, people that leave the switch ON and switch the power on a surge protector strip may end up having corroded contacts over time because they do not get regular use.  I think a lot of people that do this are scared of the spring breaking mainly though.

Maybe the deoxit did make it down there though... I'd love to know for sure, but for now I'm a bit skeptical.

Did you try to turn it on and off many times before using Deoxit?  If so, and right after using Deoxit some more on/off cycles fixed it... I guess it did make it down in there :D 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...