Jump to content

m.e.s.s. v.36 nothing but problems


Recommended Posts

OK, I finally decided to try running some 7800 stuff on my PC using m.e.s.s. v.36 and the current beta and have had nothing but problems. The readme or text files included are absolutely worthless. They are vague at best and none of the commands listed work at all. It just tells me it doesn't recognize what I entered with the option to continue anyway or cancel. When I use the windows interface most of the time it tells me "missing or corrupt ROM file" and won't run. But if I put "a7800" on the command line it runs the emulator every time but won't recognize any game files I put on the command line. The windows interface only seems to work when I select joust for centipede. Any other A78 file just gives me the message above. I downloaded all the binaries on this site and I don't think they all can be bad except two. Beside, I can’t get this emulator to even run joust or centipede two times in a row. I looked in other posts and have tried moving the 7800.rom file to different locations like "BIOSa7800.zip" or "BIOSa78007800.rom" but can only get it to work once in a while if I place the files in "ROMa78007800.rom". Any other location and the command prompt won't recognize the 7800.rom file. I really don't care if I have to use the Windows interface or the command line options as long as I can get something to work correctly. I can’t find any Documentation that even tells you were all these files should go. So maybe I just have things in the wrong locations. I've tried placing the A78 files in different places with no luck. My current setup I have file in the following places.




Softwarea7800*.A78 (all my unzipped A78 files)


I really want to get this working.


As a side not I noticed a fix for the real 7800 console that lets it run Supercharger games. Someday I hope to give that a try because I really loved those games and have everyone that was every released.

Link to comment
Share on other sites


Hey Wimp:

Download MESS 37b and put files like this:





BTW MESS emulator is very good, just look at ballblazer running now, near perfect.


I hope this info helps you.



Now I can get Joust and Centiped to work but nothing else? What do I need to run all the other 7800 titles?

Link to comment
Share on other sites

I am running Windows 98 on an AMD K6-2/400.

I have MESS32 0.37 beta 15 (just cmae out a couple of weeks ago).


I use it to emulate a whole wack of different machines (AdventureVision, Coleco, 5200, 7800). It generally runs about 80% of all ROMs, and usually does a pretty good job of it.


I have my *.a78 game roms sitting in a directory called C:emuMESSromsA7800


The system ROM is named 7800.rom and is in C:EMUMESSbiosa7800

Link to comment
Share on other sites

For 7800 on MESS:


- put a7800.zip into BIOS OR a7800.ROM into BIOSa7800 (either should work; on the Mac, the "BIOS" folder should be called "ROMs")

- put all 7800 game ROMs into Softwarea7800


To start this from the command line:

MESS a7800 -cart cartname.ext

where "cartname.ext" is the name if your cartridge ROM with the extension it has (.a78, .bin, whatever)


BTW, this is all in the MESS.TXT file and the 7800 is a system which will NOT run without a cart installed, so you can't just type "MESS a7800" and expect it to pick a game out of a hat.

Link to comment
Share on other sites

Don't feel bad about having a hard time getting MESS to run. When I started back to work on the 7800 driver a couple weeks ago, it even took me a while to get it going!


There was a discussion recently on the MESS development mailing list about the poor quality of the docs. I believe work is going on to fix this.



Link to comment
Share on other sites

OK, I see one problem now, before I didn't have and executable called "mess.exe" only "mess32.exe". Now after updating to the current beta I have the "mess.exe" now. I wonder what happened to it before. So now the readme makes some sense. The "mess32.exe" doesn't work with the command line options; well it just doesn't seem to work at all. I finally got something other than joust to run so if I don't respond any time soon its because I'm finally playing some games!


Thanks to everyone for the help


[ 09-07-2001: Message edited by: WimpMiester ]

Link to comment
Share on other sites



I'm VERY happy to see you working on the Atari 7800 driver. I have my PAL ROM dump of Impossible Mission just waiting to be played and beaten.


Even if PAL support isn't planned for the future. Rampage, Kung-Fu Master, and other NTSC titles are just waitng ;-)




PS Don't worry, I'm not going to bug you about the progress. I'm excited just to see you still have an interest in working on Atari emulators!

Link to comment
Share on other sites

You are going to have to create a batch file with options to select a specific letter and have it type the command for you. I have done it in the past but it requires that you understand certain DOS commands.


Here is a simple example to choose 2 options.



@echo off

Echo A) game 1

Echo B) game 2

choice /c:ab Choose an option

if errorlevel 2 goto game2

if errorlevel 1 goto game1



mess a7800 -cart -cartname.ext

goto stopit



mess a7800 -cart2 -cart2name.ext



echo thanks for playing!



Each letter you had after a and b becomes another errorlevel and has to be included on the choice command line. In addition, you have to create the section to issue the command and it has to have the same name as you typed after the goto. The section has to have the ":" symbol in front of the name and have the command that you want to have the system type for you on the next line after the section name. You should also have a goto at the end of the section that skips all the other sections and goes to the end so that it skips running a section by mistake.


I hope that helps.

Link to comment
Share on other sites

I know DOS and making a batch file isn't a problem. But what I was thinking of was taking the box art and making it into an icon for each title and then associating the game images to mess so you can open a program group and just click on any game you want to play. It would be easier if command options were in one place but it looks like I only need to set two options so it won't be that big of a deal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...