Jump to content
  • entries
    46
  • comments
    9
  • views
    48,358

I think my Diamond Daze Is Over


k-Pack

351 views

I have worked long and hard on a NTS-1 Patch Editor to make it operate with the Diamond GOS.  But I fear that it will never work on my system.  Strange things started happening as the last of the routines were being worked on.  It's taken me a couple of months to realize that the drive to continue working with Diamond was at an end.

 

Over time there were bugs showing up in this compiled program in an ever-increasing frequency.  These were problems with code that had already been debugged. At some point I noted that the Free Space reported at the end of the M65 assembly process was all over the place.

 

The real surprise was when an operational program was downloaded from a previous blog entry and would not compile into a working version. Then I couldn't get a simple show-me-a-Dialog-box program to compile and run.

 

I don't have the drive to figure out the problem.  It could be the Diamond and/or MAC65 Cart, or the computer.  I've even wondered if the power supply might be part of the problem.

 

And…. There is a real possibility that I wasn't up to the programing challenge. This program did require some parts of my brain that hadn't been simulated for some time.

 

Now, I still want utility programs for the NTS-1 and the MIDI MUSIC SYSTEM. They just won't be running under a GOS.

 

Please leave me a thumbs down if you're devastated by this news.

0 Comments


Recommended Comments

There are no comments to display.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...