Jump to content

Problem with ATX file

Recommended Posts

1 minute ago, mozzwald said:

This is interesting. SIO2BT firmware uses PlatformIO Espressif32 v3.2 and the 'normal' builds use v3.4. Still, if it worked on 6/5/22, I wonder what might be the cause. So you've tested all normal builds newer than 6/5/22 and confirmed the issue is present in all of those?

I didn't try all of them. I tried the following firmware revisions:

2022-08-28 - doesn't work,

2022-09-06 - works (SIO2BT build)

2022-09-22 - works

2022-10-04 - works

2022-10-12 - works

2022-11-06 BETA2 - works

2023-01-25 - works

2023-01-30 (non-SIO2BT build) - works


At first, it seemed like everything would fail after 2022-08-28. One thing I did do is to reformat my SD card under Windows as an 8GB card. Initially, that didn't appear to help. However, now I'm wondering if that fixed something after I reflashed the firmware. I had a strange error in macOS Disk Utility when I tried to erase the 16GB card. Therefore, I went to my work Windows laptop and resized the SD card to be only 8GB. The rest of the space will be wasted,  but that's more than enough space for the programs that I'll run from the SD card on Fujinet.


If the problem was simply the SD card, then I'm happy. I don't know why the other 16GB Sandisk card didn't work for me either. I don't have any actual 8GB microSD cards lying around here.


Now both MLB and the Translator/Bible Baseball combination appear to be working.


Bob C


Link to comment
Share on other sites

Just to try to tie up this topic, I purchased a Sandisk 8GB microSD card. Since I had to buy it from an Amazon third-party seller, there's no guarantee that it isn't a Sandisk ripoff instead of a legit Sandisk card. However, that card works correctly on my Fujinet. I don't know why the Sandisk 16GB microSD card that I have in my Sdrive Max didn't work with the sample ATX files on Fujinet.


However, I've determined that (for some reason) my particular Fujinet board doesn't like to load ATX files if the microSD card is more than 8GB.  I'm curious why ATR files were unaffected though. I never had a problem loading an ATR file with the generic 16GB microSD card that the Fujinet came with.


As I said though, simply using an 8GB card appears to eliminate all of the problems I was having with ATX files. An 8GB card is more than enough space until I can have my MacBook Air available full-time to be a TNFS server.


Bob C

Link to comment
Share on other sites

21 hours ago, _The Doctor__ said:

so is this a memory problem? run out of space mounting average SD volumes?

a limit of some kind?

@_The Doctor__ - Without being @mozzwald, I have two best guesses:

1. Both my generic (Eastbull?) and Sandisk 16GB microSD cards are problematic with Fujinet. I don't want to keep buying 16GB cards until I get one that (may) work. The Sandisk card I have works great with my Sdrive Max, but it has problems with some ATX files on Fujinet. 

2. There's a hardware problem on my particular Fujinet that prevents me from using a microSD card larger than 8GB. I'm assuming some Fujinet users are running programs from a 16GB card. It sounded like Mozzwald had a 16GB card at his disposal and was unable to duplicate my problem.


If you look at the spoiler text that has the logs, mozzwald immediately pointed out a call to the SD card that failed. Again, it could be a problem with multiple microSD cards or it could be my individual Fujinet. Unless other people can repeat my problem on multiple Fujinets and multiple microSD cards, I have to assume it's a problem on my end.


That leads me to believe it's a "one off" problem on my end. I've tried to give the solution as much as I understand the situation. When I'm searching for answers, nothing irritates me more than "it works now" with no explanation of the possible solution. While I'm not a hardware engineer, I've tried to give my solution in case another person runs into the same problem in the future.


Bob C

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...