Jump to content

7800basic beta, the release thread


Recommended Posts

So my question is...how do i start a new Project????With the text Editor????not with 7800basic?????

Yup, that's correct. This is the way modern languages do it. You pick a text editor and write the code in your editor, instead of using one provided with the language.


Even when when you're provided an editor with the language, like with Microsoft Visual languages, you can still pick your favourite text editor and use it to enter code, instead of using the provided one.



the error,i get is too fast,but it is in the window with White text...

Hope you can help

[edit - Do what CPUWIZ suggests first, then...]


unzip the attached file into one of the sample directories. Then double-click the "7800compile.bat" and let us know if it works, or if it provides some other error.



Link to comment
Share on other sites

Progress, but not a solution.


The window with c:\Windows\System32 is a CMD window. The one that we tried to open with "start>run cmd". Strange that it opens with double-clicking, but not from the RUN box.


From the CMD window, can you please type the following and tell me what the output of each line is?


echo %bas7800dir%

echo %PATH%

Link to comment
Share on other sites

The CMD.txt looks fine, but wow, that output.txt wasn't what I expected, and very different from the run on my own system. To me it looks like something is actively trying to kill the batch process as soon as its run. I suspect this is why your "START->RUN CMD" attempts closed themselves too.


If you haven't virus scanned in a while, you may want to give that a shot. If its not a virus causing this, I'm stumped.


If a virus scan comes up clean, and if double-clicking CMD.exe (per CPUWIZ) works without closing things, try steps 2 and 3 with that CMD window...


2. type: cd \my\project\directory (substitute the directory that contains your BASIC source)

3. type: 7800bas.bat myprogram.bas (substitute the filename containing your BASIC source code)

Link to comment
Share on other sites

I like the audio command suggestion. It will waste a small bit of rom bytes and cycles changing registers that may not change, but that choice would be up to the basic coder.


What about making the parameters optional, so the programmer could do something like


TSOUND channel, freq, waveform, volume ; to set all parameters at once

TSOUND channel, freq ; to set just the frequency

TSOUND channel, , waveform ; to set just the waveform

TSOUND channel, , , volume ; to set just the volume

; or some combination of the above:

TSOUND channel, freq, waveform

TSOUND channel, freq, , volume

TSOUND channel, , waveform, volume

  • Like 1
Link to comment
Share on other sites

Hi RevEng,Hi Guys


have a look at the text,i added

I started the whole from beginning(see text)

It nearly worked....this means,the windowcsreen did not disappear :)

But when trying to compile...........The a 78 and bin files are there but with 0 Bytes :(

greetings Walter


This is,what appeared in the window




C:\7800\7800basic.0.1beta20140228\samples\simple>7800bas.bat *.bas
^CBatchvorgang abbrechen (J/N)? n
Cannot open includes.7800 for reading

Cartridge data file must be at least 4K!

7800header 0.1 Feb 28 2014 22:36:53
opened parameter file a78info.cfg


Link to comment
Share on other sites

The core of the problem is that when you run the batch file, even from the CMD prompt, something is trying to kill it. I know you typed "N", but it likely didn't work, or it interfered with passing the output of one program to the input of another.


Can you try START->RUN and type "regedit", or START->RUN and type "msconfig"?


Don't change anything with these programs, but if these close immediately, its likely a virus that's interfering here.

Link to comment
Share on other sites

Also, when it comes to the POKEY, you could do commands similar to TSOUND ...


SOUND chan,freq,waveform,volume (just like on Atari BASIC)


And also DSOUND chan,freq,waveform,volume (like in Turbo BASIC) for when you use POKEY in 16-bit mode ... this works by setting AUDCTL to where you can combine two channels to make one 16-bit channel, giving you greater note resolution. Makes it possible to play bass notes in distortion 10 (square) or high-range melodies in distortion 2 (triangle) and 12 (saw).

  • Like 4
Link to comment
Share on other sites

Hi Walter,


Did you try running "regedit" or "msconfig" from START->RUN? Did they stay open?


You were running the correct commands to compile a basic game from CMD.EXE, when you typed "7800bas.bat *.bas"


We won't be able to make 7800basic work on your computer until we figure out why it's auto-terminating batch jobs. This isn't standard Windows behaviour.


Anybody else have any bright ideas?

Link to comment
Share on other sites

beta 0.1 20140306 is now in the first post, replacing the old version.


quoth the changelog...

  • added some sanity-checking to install_ux.sh.
  • miscellaneous Guide updates, per forum feedback and new commands.
  • added "converttobcd()" function, courtesy of Omegamatrix.
  • added "boxcollision()" function.
  • added tsound command.
  • fixed a few commands that inadvertently used the wrong stack location.
  • Like 6
Link to comment
Share on other sites

Judging by the number of people that have downloaded the update, I'm guessing we probably have a few projects in the works.


I have a game idea I'm working on, but it's not ready to share yet. It may be a while yet, since I'm spending a lot of time working on 7800basic itself. :)


I'd also like to turn Adventurer into a real game at some point. I'm thinking of something thats a cross between Adventure and The Legend of Zelda. But that will be a long while at the current pace.

  • Like 1
Link to comment
Share on other sites

Just a heads up to all that I'm working on some additional functionality.


I started working on an example with sprites interacting with map characters, when I decided that the existing rom/memory character access methods - i.e. using arrays - is a bit weak. It's currently a bit difficult to access, say, the character in the 7th row down and 7th column over.


The peekchar and pokechar commands I'm working on should make lookups a lot easier. I also implemented a "memcpy" command, which is handy for copying ROM to RAM, for loading levels that need to be modified as play happens. (like Sky Scraper, pacman, etc.)

Edited by RevEng
  • Like 4
Link to comment
Share on other sites

I finally had some time to sit with this and slug it out with the thing. I ran into the same color issue as Allan did, but switched to Gimp and got it all sorted out. After that, things just sort of fell into place.


I got a sprite on the screen!


And then I realized that I forgot to loop the thing. Fixed it up, and then made the sprite move!


And now I have an idea for that little sprite!


Thanks RevEng and the gang! :)


(Hey, it's gotta start somewhere, eh?)

Edited by MAC-42
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...