Jump to content
IGNORED

PlusCart(+) + SD


Andrew Davie

Recommended Posts

18 hours ago, kyokorn said:

Hello friends, recently i get some pluscart duo pcb, I can see the boot logo, after the logo the screens goes to black :(

Maybe a voltage issue. Have you tested a different 2600?

has the 2600 you use a video mod?

Link to comment
Share on other sites

1 hour ago, Al_Nafuur said:

Maybe a voltage issue. Have you tested a different 2600?

has the 2600 you use a video mod?

Hello friend, 

 

Yes my 2 ataris have the video mod, and the issue is the same on the 2 ataris, but is strange because on the past i build and test it a couple of pluscart and was working fine, maybe just the AC\DC adapter is another now, your recommendation is test with other AC/DC adapter ? Or maybe the problem is because the video modification ?

 

BR

Link to comment
Share on other sites

3 hours ago, Al_Nafuur said:

Maybe a voltage issue. Have you tested a different 2600?

has the 2600 you use a video mod?

Jesus, I change the AC/DC Adapter, also I did the test on the 5 ataris that i have with the same result, I have 2 ataris Jr that don't have the video mod, but is the same result. 

 

I checked it point by point and the solder points looks good, also i did the test with different firmwares and the result is the same, after plus logo (+) the screen goes black 

 

Any ideas? 

 

Many Thanks in advance!

LB

Link to comment
Share on other sites

9 hours ago, kyokorn said:

Jesus, troquei o adaptador AC/DC, também fiz o teste nos 5 ataris que tenho com o mesmo resultado, tenho 2 ataris Jr que não tem o mod de vídeo, mas dá o mesmo resultado. 

 

Verifiquei ponto a ponto e os pontos de solda parecem bons, também fiz o teste com firmwares diferentes e o resultado é o mesmo, depois do logo de mais (+) a tela fica preta 

 

Alguma ideia? 

 

Muito obrigado antecipadamente!

LIBRA

use a 9v power supply and at least 1A.

  • Like 1
Link to comment
Share on other sites

You can do some tests:

 

1) Check the output voltage from your 7805 regulator. If It is less then 4.7v you can have the same problem as the one I reported above.

 

2) Use a external DC Power supply, and look at the amps you Atari drains. Your 7805 can be entering in the protection state, that turn It off. The same problem as 1)

 

3) Remove the wi-fi board and test it. The menu appears?

 

Good Lucky!

 

  • Like 1
Link to comment
Share on other sites

1 hour ago, Capellão said:

use a 9v power supply and at least 1A.

I did my friend, I used a new 9V 1A power supply, but i will try to get a new one. 😃

1 hour ago, cfarl said:

You can do some tests:

 

1) Check the output voltage from your 7805 regulator. If It is less then 4.7v you can have the same problem as the one I reported above.

 

2) Use a external DC Power supply, and look at the amps you Atari drains. Your 7805 can be entering in the protection state, that turn It off. The same problem as 1)

 

3) Remove the wi-fi board and test it. The menu appears?

 

Good Lucky!

 

Hello friend, nice tips, I will test the voltage drain, and see what happend wihout the wifi board, 

 

BR!

Link to comment
Share on other sites

Posted (edited)

Well I'm a little frustated, because i did everthing and same result, here the resume:

 

* The drain voltage looks good. 

* Without the wifi board when I turned on the atari is on black screen. (I cannot see the plus logo (+))

* I was thinking that maybe the problem is on the PCB (I mean this new PCB pluscart duo), but I have the original PCB just pluscart without sd, and this new atari pluscart that i build is on black screen (either i can't see the pluscart logo)

* That I found is the esp show an ssid  AI_THINKER_XXXX, I think this is not normal?  Well anywway I did the process to load the firmware in to the ESP, but with the same result in the 2 Pluscart original and pluscart DUO (Black screen).

 

I get 4 boards STM32F407VGT6 , 2 of them is imposible put in to flash mode to load the .elf file, maybe can be a bad lote of these boards? Exist anyway to test the boards ?

 

On the past I built 4 pluscart to my close friends (Birtday present) and works without any problem at the first attemp, this time the luck is not with me :(

Edited by kyokorn
Link to comment
Share on other sites

15 hours ago, kyokorn said:

* Without the wifi board when I turned on the atari is on black screen. (I cannot see the plus logo (+))

I am not sure, but I think you need a firmware without WiFi (PlusCart Zero or UnoCart firmware) to test this.

 

Link to comment
Share on other sites

  • 3 weeks later...
On 2/24/2023 at 8:31 AM, Al_Nafuur said:

New public version v102.3.17 for PlusCart Duo.

  • Disable exit function with file name key/extension ".noexit"

PlusCart Duo user have to flash the firmware manually with the STM32CubeProgrammer via USB or ST-Link, or rename the .bin file to "firmware.bin" and put it in the root folder of your SD-Card.

The new firmware file is bigger than 112 KiB, so only PlusCart Duos with firmware version v102.3.1 and higher can update via SD directly to v102.3.17 (all others will have to do 2 updates in a row).

 

PlusCart_Duo.bin 126.56 kB · 66 downloads

PlusCart_Duo.elf 267.33 kB · 64 downloads

Master, is this the latest firmware version? 
Thank you very much! Greetings from Chile!

Link to comment
Share on other sites

15 minutes ago, pablo.cl said:

Master, is this the latest firmware version? 
Thank you very much! Greetings from Chile!

Yes it is the latest.

 

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...