Jump to content

Upcoming Virtual Jaguar 2.0.0 release


Recommended Posts

Maybe there's a switch in qmake that turns off those Apple specific flags? Or you could try removing them from the generated Makefile by hand. :P


I manually forced the build to complete with both GCC 4.5 and 4.7. Both have the same performance issue, so it's something specific to the platform that's causing problems.


I also tried building on an older OS X 10.6 platform with the same results.




I also updated QT to 4.8.4 and tried various optimization levels (O3, Ofast, O0). Neither of those made a difference either.


Haven't tried QT 5 yet, but that's due to a compile issue on OS X. Hopefully that will be fixed shortly, so I can finally start using it.

Link to comment
Share on other sites

Now that is strange, I wonder what flavor of Linux he's using? Because in both the virtualjaguar.pro and the generated makefile-qt the -lz is in there. I wonder if his version of qmake stripped it out? Also strange that it linked without it, as -lz is a requirement for the Jaguar core library. :P


@goldendegg: I'm stumped. It could be that there's a 32 vs. 64 bit issue there, with some kind of translation causing the slowdown; without dissecting it and being able to look at the pieces it's next to impossible to say what it is that's gone wrong there. :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...