Jump to content
IGNORED

MAME just bloated up again.. Post new mame bloat here.


Keatah
 Share

Recommended Posts

The rendering options have improved dramatically within the last year, especially if you are interested in emulating the CRT scanline look with the use of shaders.

My advice if starting from scratch and you aren't worried about internet usage caps is to get the latest version romset you can find and use the Mame version that matches it. There have been some fairly recent changes in the Capcom CPS2 game dumps recently (.key encryption file and qsound) which makes the older versions of those roms incompatible with the newest versions of Mame.

  • Like 1
Link to comment
Share on other sites

Don't know. It kind of becomes a trade-off between how much work you want to put into reconfiguring things and getting some new games working. Everyone is going to be different.

 

Might be best to upgrade just the games you're looking for, and that means a separate installation for each "batch" of improved games.

Link to comment
Share on other sites

Yeah if you only want a very small selection of game ( < 50 ) you wouldn't be bad off finding and downloading each game one at a time and getting it working. But if you want something like the top 100 or 200 or so games then downloading a full set and then pulling out the games you want would be less time consuming.

  • Like 2
Link to comment
Share on other sites

Thanks.. looks good, but it seemed to be missing some games or is it me? For some reason the first game I looked out for was Marine Date (to see if it had any improvements yet), and it's not listed. Go figure.

I think they also filter out games that don't work. I still think its easier to have one mame than having a separate one for consoles/computers. MameUI64 makes it easy.

 

mousetrap doesn't work due to missing roms. Exidy shooters don't have collision detection anymore. Lazarian sounds haven't been fixed ,and astro fantasia colors are wrong all while they add games and screw up perfectly working ones. It went downhill after retrograde was discontinued. The preservationists are ruining Mame trying to make everything perfect. we need another emulator to challenge mame.

That exidy shooter bug was fixed in v.187. http://mametesters.org/view.php?id=6596

If you find bugs you should report them at mametesters. http://mametesters.org/view.php?id=6541

 

-------------------

The mame and rom set version match is not required. I've been using the same v.153 set with mame v.18x. I only update individual roms as required. Some might be difficult to find when new. Copying the few custom controller configuration files to different mames is easy.

Edited by mr_me
Link to comment
Share on other sites

That makes sense. Still it surprises me that they can find people interested in emulating some really obscure pieces of coin-op hardware but can't find anyone interested enough to fix the fairly mainstream systems that are still broken in the MESS portion.

 

 

 

I would disagree a bit. I think what they should do is give the user a warning to the effect that this romset is deprecated and may be discontinued in the future if the code that supports it breaks. For the most supported romset, obtain "xx"

 

And the romset names should never change, instead they should be appended with a dump revision like pacman pacman_d02 pacman_d03. That would minimize all the confusion of which romset named "pacman" goes with which version of Mame, and what does it need to be named to work-- which causes so much frustration right now.

 

Not really surprising at all, emulating a system from scratch is fun, debugging someone else's code, not so much. What you suggest about the roms just makes things more complex from a development standpoint. Since the goal is to preserve the most accurate rom set possible, it makes sense to drop support for something that is not the best known set.

  • Like 1
Link to comment
Share on other sites

What you suggest about the roms just makes things more complex from a development standpoint. Since the goal is to preserve the most accurate rom set possible, it makes sense to drop support for something that is not the best known set.

When you have mame running on different devices that use different base versions of mame (slower devices requiring older versions of mame), and are interested in emulating maybe 20-30 games, then managing those roms is a nightmare. The roms are not versioned in any way, which makes it hard to figure out which rom works with which emulator except through trial and error. So I don't know why they can't be versioned with a dump revision. (you have pengo dump v2, this version of mame requires dump v4) even that would help a lot.

  • Like 1
Link to comment
Share on other sites

When you have mame running on different devices that use different base versions of mame (slower devices requiring older versions of mame), and are interested in emulating maybe 20-30 games, then managing those roms is a nightmare. The roms are not versioned in any way, which makes it hard to figure out which rom works with which emulator except through trial and error. So I don't know why they can't be versioned with a dump revision. (you have pengo dump v2, this version of mame requires dump v4) even that would help a lot.

 

Because you are assuming that the primary goal of MAME is to make an emulation platform that is easy for everyone to use which is not the case. The preservation aspects, In most cases, take precedence over user experience.

  • Like 2
Link to comment
Share on other sites

M.A.M.E. has to hide behind something. Might as well be "preservation". But it only does half of the preservation, nowhere near full. Because the other half is the roms. Roms that you have to go off on a hunt for. So imagine the plight of the future digital archaeologist. the poor sap is going to have to continue searching like we do today.

Link to comment
Share on other sites

Almost sounds like a snooty coders only club and only those who can compile their own stuff, or slog through a double digit GB sized torrent per release can have their fun without issue.

There's lots of aleady compiled Mames ready to run for different operating systems and computers including the raspberry pi. Some like MameUI64 have really nice interfaces. No need to download a 50GB rom set; roms files for individual machines can be found. Noone has the right to distribute all those rom images so finding the one you want is not guaranteed. As someone has mentioned, Mame is made up of many, many projects and many, many programmers. Hard to expect consistency with changes. Emulation accuracy is important and sometimes that calls for faster computers. Sometimes they do change a rom image filename when the file hasn't changed, I wish they didn't.

 

Here you can find very old rom sets and even get individual files. https://archive.org/details/MAME0.37b5_MAME2000_Reference_Set_Update_2_ROMs_Samples

 

For mames released in the last couple of years any modern set should work.

Link to comment
Share on other sites

M.A.M.E. has to hide behind something. Might as well be "preservation". But it only does half of the preservation, nowhere near full. Because the other half is the roms. Roms that you have to go off on a hunt for. So imagine the plight of the future digital archaeologist. the poor sap is going to have to continue searching like we do today.

 

Why do you feel the team needs to "hide" behind anything? Preserving ROMS is a totally different thing that comes with significant legal challenges, not something a team of volunteer developers want's to deal with. MAME does the next best thing, and provides a tool that can verify that the ROMS you have found are what was in the original machine.

 

I got involved in the MAME development close to 20 years ago, and I have seen these type of "attacks" on the project since day one, but I can never understand people who attack the project because it doesn't work they way they want it to. MAME is written by a group of hobbyists that do it because they enjoy doing it, and they do what they want to do. If people don't like it, they don't have to use it, or they can go off an try to write something better (which has happened in the past). Constructive criticisms is fine, but statements like "they're doing some bullshit development system" and "Some idiot with "pet-project" mentality" are by no means constructive.

  • Like 4
Link to comment
Share on other sites

I think I would recommend 3 things to people who are gamers and see MAME as a way to play games:

 

1) Don't update frequently

--Stick with a build that works and play the thousands of games you have. You'll probably be dead before you need an update anyway

 

2) Find a membership site for Roms

--Someone got me to a site called "pleasuredome" some time ago and it has been easy ever since. There are others.

 

3) Use CLRMamePro to "correct" Roms

--It works

  • Like 5
Link to comment
Share on other sites

Works fine for me, the mame installation here is v0.30 from 1998 or so. :)

 

Same here.

 

I have no idea what version of MAME I am running, nor do I care. It plays the small handful of games that I want to play (mostly titles not included in one or another commercial emulation package). It may not be 100% arcade accurate, but it is good enough for my needs.

 

It may not accurately play games that I do not like, and it very definitely lacks functions and features that I will never use. I do not see this as a problem.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

I kept a few versions where landmark changes occurred...

 

From memory:

0.106 because after that, the video rendering was improved/slowed down so it doesn't work on older hardware well.

0.131 because after that, all cocktail flipping was broken. I don't know if that was ever fixed. I have a MAMEd cocktail machine... :)

 

I also have 0.35, 0.79 and 0.84 but now I forget why... maybe someone from the old days can remind me.

Edited by R.Cade
Link to comment
Share on other sites

Over time some rom image files changed names even when the image itself didn't change. That would have been upto the individual programmer of the individual machine driver. This made newer sets incompatible with older mames for certain games. But this hasn't happened for a very long time.

Link to comment
Share on other sites

I keep a .36 set, I think that's around the change from 32 to 64 bit, or just the set that still made emulators for very low end systems/handhelds. I don't quite remember the exact reason it's a good version.

 

My last update was .170, and that has pretty much every game I want to play. Oh, the latest version adds another 37 naked Japanese Mahjong games? Woo.

Link to comment
Share on other sites

Is there a seperate version of mess without the mame stuff so I can play bally astrocade games?

 

Mess used to be separate.

 

I think if you want to screw around with the makefiles, you may be be able to strip out what you don't want and produce a slim(mer) version.

Link to comment
Share on other sites

:D

 

You know the worst thing about Mame developers? The Mame Developers. They are the rudest bunch of condescending a**holes I've ever had the misfortune to communicate with. God forbid you ever ask them abut playing a game, or make a suggestion. Goodness no - they'll blast you for not liking what you get.

 

The built in UI is a disaster. It is so very clearly written by people who know noting about designing and testing UI's. It's absolutely horrid. I stopped grabbing new versions because I finally got a version that worked for what I wanted. I won't upgrade Mame again. For every fix they make to a game, something else breaks. And you know what - if you're just a user, they basically hate you anyway. There were some good Mame UI's for Windows, but even the developers of those were attacked by Mame guys.... It's a great project, but damn, they're miserable b*astards.

  • Like 5
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...